aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-01-12 21:36:23 +0900
committerPetr Štetiar <ynezz@true.cz>2020-07-08 23:22:30 +0200
commit358aec77756d6bf850a533272f2685a45220dc0c (patch)
tree6d28b534f25267ab28af866abb92ec92b057f3a9 /target/linux/ath79/image
parentdc61e3b7ffdc2e3873af238a9100d44ee685578c (diff)
downloadupstream-358aec77756d6bf850a533272f2685a45220dc0c.tar.gz
upstream-358aec77756d6bf850a533272f2685a45220dc0c.tar.bz2
upstream-358aec77756d6bf850a533272f2685a45220dc0c.zip
ath79: add support for Arduino Yun
Arduino Yun is a microcontroller development board, based on Atmel ATmega32u4 and Atheros AR9331. Specifications: - MCU: ATmega32U4 - SoC: AR9331 - RAM: DDR2 64MB - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: SoC internal - Ethernet: 1x 10/100Mbps - USB: 1x 2.0 - MicroSD: 1x SDHC Notes: - Stock firmware is based on OpenWrt AA. - The SoC UART can be accessed only through the MCU. YunSerialTerminal is recommended for access to serial console. - Stock firmware uses non-standard 250000 baudrate by default. - The MCU can be reprogrammed from the SoC with avrdude linuxgpio. Installation: 1. Update U-Boot environment variables to adapt to new partition scheme. > setenv bootcmd "run addboard; run addtty; run addparts; run addrootfs; bootm 0x9f050000 || bootm 0x9fea0000" > setenv mtdparts "spi0.0:256k(u-boot)ro,64k(u-boot-env),15936k(firmware),64k(nvram),64k(art)ro" > saveenv 2. Boot into stock firmware normally and perform sysupgrade with sysupgrade image. # sysupgrade -n -F /tmp/sysupgrade.bin Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 14e72140dc..46a8705b85 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -210,6 +210,17 @@ define Device/alfa-network_ap121f
endef
TARGET_DEVICES += alfa-network_ap121f
+define Device/arduino_yun
+ SOC := ar9331
+ DEVICE_VENDOR := Arduino
+ DEVICE_MODEL := Yun
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-chipidea2 kmod-usb-ledtrig-usbport \
+ kmod-usb-storage block-mount -swconfig
+ IMAGE_SIZE := 15936k
+ SUPPORTED_DEVICES += arduino-yun
+endef
+TARGET_DEVICES += arduino_yun
+
define Device/aruba_ap-105
SOC := ar7161
DEVICE_VENDOR := Aruba