aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-08-20 16:32:42 +0900
committerMathias Kresin <dev@kresin.me>2018-08-23 22:42:15 +0200
commit30b4f78193768f7154337d8b66f6346c1fd1474f (patch)
treeae858e714ea07a8d769f2889cf6351c90369e89f /target/linux/ath79/image
parent524c17d8654a3137a1de8e59cf4a9881575b7285 (diff)
downloadupstream-30b4f78193768f7154337d8b66f6346c1fd1474f.tar.gz
upstream-30b4f78193768f7154337d8b66f6346c1fd1474f.tar.bz2
upstream-30b4f78193768f7154337d8b66f6346c1fd1474f.zip
ath79: add support for I-O DATA ETG3-R
I-O DATA ETG3-R is a wired router, based on Atheros AR9342. Specification: - Atheros AR9342 - 64 MB of RAM - 8 MB of Flash - 5x 10/100/1000 Ethernet - AR8327N - 2x LEDs, 1x key - UART header on PCB - Vcc, GND, TX, RX from ethernet port side - 115200n8 Flash instruction using initramfs image: 1. Connect serial cable to UART header on ETG3-R 2. Rename OpenWrt initramfs image to "1500A8C0.img" and place it in the TFTP directory 3. Set IP address of the computer to 192.168.0.10, connect to the LAN port of ETG3-R, and start the TFTP server on the computer 4. Connect power cable to ETG3-R and turn on the router 5. Press "Enter" key when the "Hit any key to stop autoboot:" message is displayed on the console and enter the u-boot cli 6. execute following commands to change kernel address for u-boot setenv bootsf 1 setenv mtd_kernel1 "bootm 0x9f050000" saveenv 7. execute "tftpboot; bootm" command to download the initramfs image from TFTP server and boot with it 8. On the initramfs image, execute "mtd erase firmware" to erase stock firmware and execute sysupgrade with sysupgrade image for ETG3-R 9. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 18138dd497..e35a3568a8 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -80,6 +80,13 @@ define Device/glinet_ar300m_nor
endef
TARGET_DEVICES += glinet_ar300m_nor
+define Device/iodata_etg3-r
+ ATH_SOC := ar9342
+ DEVICE_TITLE := I-O DATA ETG3-R
+ IMAGE_SIZE := 7680k
+endef
+TARGET_DEVICES += iodata_etg3-r
+
define Device/iodata_wn-ac1167dgr
ATH_SOC := qca9557
DEVICE_TITLE := I-O DATA WN-AC1167DGR