aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2020-12-17 17:24:26 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-19 19:42:00 +0100
commit0d96d36841e817f368e86d4af725570d757cb0ca (patch)
treea8cbdb733968385aacd69c06face94735e6f9a9c /target/linux/ath79/image
parentd69ec61f7d51f4fb671345043bc6d8e4fe916815 (diff)
downloadupstream-0d96d36841e817f368e86d4af725570d757cb0ca.tar.gz
upstream-0d96d36841e817f368e86d4af725570d757cb0ca.tar.bz2
upstream-0d96d36841e817f368e86d4af725570d757cb0ca.zip
ath79: add support for AirTight C-75
AirTight Networks (later renamed to Mojo Networks) C-75 is a dual-band access point, also sold by WatchGuard under name AP320. Specification SoC: Qualcomm Atheros QCA9550 RAM: 128 MiB DDR2 Flash: 2x 16 MiB SPI NOR WIFI: 2.4 GHz 3T3R integrated 5 GHz 3T3R QCA9890 oversized Mini PCIe card Ethernet: 2x 10/100/1000 Mbps QCA8334 port labeled LAN1 is PoE capable (802.3at) USB: 1x 2.0 LEDs: 7x which two are GPIO controlled, four switch controlled, one controlled by wireless driver Buttons: 1x GPIO controlled Serial: RJ-45 port, Cisco pinout baud: 115200, parity: none, flow control: none JTAG: Yes, pins marked J1 on PCB Installation 1. Prepare TFTP server with OpenWrt initramfs-kernel image. 2. Connect to one of LAN ports. 3. Connect to serial port. 4. Power on the device and when prompted to stop autoboot, hit any key. 5. Adjust "ipaddr" and "serverip" addresses in U-Boot environment, use 'setenv' to do that, then run following commands: tftpboot 0x81000000 <openwrt_initramfs-kernel_image_name> bootm 0x81000000 6. Wait about 1 minute for OpenWrt to boot. 7. Transfer OpenWrt sysupgrade image to /tmp directory and flash it with: sysupgrade -n /tmp/<openwrt_sysupgrade_image_name> 8. After flashing, the access point will reboot to OpenWrt. Wait few minutes, until the Power LED stops blinking, then it's ready for configuration. Known issues Green power LED does not work. Additional information The U-Boot fails to initialise ethernet ports correctly when a UART adapter is attached to UART pins (marked J3 on PCB). Cc: Vladimir Georgievsky <vladimir.georgievsky@yahoo.com> Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b3fca9eb8f..baaea00c30 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -237,6 +237,19 @@ define Device/adtran_bsap1840
endef
TARGET_DEVICES += adtran_bsap1840
+define Device/airtight_c-75
+ SOC := qca9550
+ DEVICE_VENDOR := AirTight Networks
+ DEVICE_MODEL := C-75
+ DEVICE_ALT0_VENDOR := Mojo Networks
+ DEVICE_ALT0_MODEL := C-75
+ DEVICE_ALT1_VENDOR := WatchGuard
+ DEVICE_ALT1_MODEL := AP320
+ DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct kmod-usb2
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += airtight_c-75
+
define Device/alfa-network_ap121f
SOC := ar9331
DEVICE_VENDOR := ALFA Network