aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorVictorien Molle <victorien.molle@wifirst.fr>2021-08-20 21:41:19 +0200
committerDavid Bauer <mail@david-bauer.net>2022-01-22 01:17:16 +0100
commitaf8a059bb41dd7afee49ce9a5d52e9a8e010bbd8 (patch)
tree17cbb21468fcc4318e8507a85773df86f09947f1 /target/linux/ath79/image
parent7c8ade1765fa283c253d7c29165be77fcd6a1ff0 (diff)
downloadupstream-af8a059bb41dd7afee49ce9a5d52e9a8e010bbd8.tar.gz
upstream-af8a059bb41dd7afee49ce9a5d52e9a8e010bbd8.tar.bz2
upstream-af8a059bb41dd7afee49ce9a5d52e9a8e010bbd8.zip
ath79: add support for GL.iNet GL-XE300
The GL.iNet GL-XE300 is a 4G LTE Wireless router, based on QCA9531 SoC. Specifications: - SoC: QCA9531 (650MHz) - RAM: DDR2 128M - Flash: SPI NOR 16M + SPI NAND 128M - WiFi: 2.4GHz with 2 antennas - Ethernet: - 1x LAN (10/100M) - 1x WAN (10/100M) - LTE: - USB: 1x USB 2.0 port - UART: - 3.3V, TX, RX, GND / 115200 8N1 MAC addresses as verified by OEM firmware: use address source LAN *:c5 art 0x0 (label) WAN *:c6 label + 1 WLAN *:c7 art 0x1002 Installation via U-Boot rescue: 1. Press and hold reset and power buttons simultaneously 2. Wait for the LAN led to blink 5 times 3. Release reset and power buttons 4. The rescue page is accessible via http://192.168.1.1 5. Select the OpenWrt factory image and start upgrade 6. Wait for the router to flash new firmware and reboot Revert to stock firmware: i. Download the stock firmware from GL.Inet website ii. Use the same method explained above to flash the stock firmware Signed-off-by: Victorien Molle <victorien.molle@wifirst.fr> [update commit message] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/nand.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index d31aba1abc..b8006c6d0c 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -195,6 +195,22 @@ define Device/glinet_gl-e750
endef
TARGET_DEVICES += glinet_gl-e750
+define Device/glinet_gl-xe300
+ SOC := qca9531
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := GL-XE300
+ DEVICE_PACKAGES := kmod-usb2 block-mount kmod-usb-serial-ch341
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 131072k
+ PAGESIZE := 2048
+ VID_HDR_OFFSET := 2048
+ BLOCKSIZE := 128k
+ IMAGES += factory.img
+ IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += glinet_gl-xe300
+
# fake rootfs is mandatory, pad-offset 129 equals (2 * uimage_header + 0xff)
define Device/netgear_ath79_nand
DEVICE_VENDOR := NETGEAR