aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-13 14:48:26 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-16 17:31:03 +0200
commitc68105c3b4f616931444174ff6d893c8fbaf9465 (patch)
treeb7a7d5d7f4d7dfd5366c0695f11f11e755771ec0 /target/linux/ath79/image/tiny.mk
parenta99614a44f205f48db4278988566d2b6b2b96295 (diff)
downloadupstream-c68105c3b4f616931444174ff6d893c8fbaf9465.tar.gz
upstream-c68105c3b4f616931444174ff6d893c8fbaf9465.tar.bz2
upstream-c68105c3b4f616931444174ff6d893c8fbaf9465.zip
ath79: use common device definition for Buffalo devices
The Buffalo devices in ath79 share their image generation code, so let's create a shared Device definition for them. Since most of them use BUFFALO_HWVER := 3, this is moved as default to the shared definition as well. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny.mk')
-rw-r--r--target/linux/ath79/image/tiny.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 9f4f89bd9a..83c34d718b 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -1,16 +1,11 @@
include ./common-buffalo.mk
define Device/buffalo_whr-g301n
+ $(Device/buffalo_common)
SOC := ar7240
- DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WHR-G301N
+ BUFFALO_PRODUCT := WHR-G301N
IMAGE_SIZE := 3712k
- IMAGES += factory.bin tftp.bin
- IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
- pad-rootfs | check-size
- IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WHR-G301N 1.99 | \
- buffalo-tag WHR-G301N 3
- IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
SUPPORTED_DEVICES += whr-g301n
DEFAULT := n
endef