aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-11-06 22:37:43 +0900
committerJohn Crispin <john@phrozen.org>2018-11-26 12:28:17 +0100
commit879f2ef7c0720c49f0911a6a3a7f8fe4111c2acb (patch)
tree32df454ec54dcb2f9df409963fdea85ed9f9ff4e /target/linux/ath79/image/tiny.mk
parentd6e92b18d9ab853a34313a0f78f98b763dc9eba4 (diff)
downloadupstream-879f2ef7c0720c49f0911a6a3a7f8fe4111c2acb.tar.gz
upstream-879f2ef7c0720c49f0911a6a3a7f8fe4111c2acb.tar.bz2
upstream-879f2ef7c0720c49f0911a6a3a7f8fe4111c2acb.zip
ath79: modify mtd partitions for Buffalo BHR-4GRV2
This commit modifies mtd partitions define for Buffalo BHR-4GRV2 and move it to generic subtarget. In Buffalo BHR-4GRV2, "kernel" partition is located behined "rootfs" partition in the stock firmware. This causes the size of the kernel to be limited by the fixed value. 0x50000 0xe80000 0xff0000 +-------------------------------+--------------+ | rootfs | kernel | | (14528k) | (1472k) | +-------------------------------+--------------+ After ar71xx was updated to Kernel 4.14, the kernel size of BHR-4GRV2 exceeded the limit, and it breaks builds on official buildbot. Since this issue was also confirmed in ath79, I modified the mtd partitions to get rid of that limitation. 0x50000 0xff0000 +----------------------------------------------+ | firmware | | (16000k) | +----------------------------------------------+ However, this commit breaks compatibility with ar71xx firmware, so I dropped "SUPPORTED_DEVICES += bhr-4grv2". This commit requires new flash instruction instead of the old one. Flash instruction using initramfs image: 1. Connect the computer to the LAN port of BHR-4GRV2 2. Set the IP address of the computer to 192.168.12.10 3. Rename the OpenWrt initramfs image to "bhr4grv2-uImage-initramfs-gzip.bin" and place it into the TFTP directory 4. Start the tftp server on the computer 5. While holding down the "ECO" button, connect power cable to BHR-4GRV2 and turn on it 6. Flashing (orange) diag LED and release the finger from the button, BHR-4GRV2 downloads the intiramfs image from TFTP server and boot with it 7. On the initramfs image, create "/etc/fw_env.config" file with following contents /dev/mtd1 0x0 0x10000 0x10000 8. Execute following commands to add environment variables for u-boot fw_setenv ipaddr 192.168.12.1 fw_setenv serverip 192.168.12.10 fw_setenv ethaddr 00:aa:bb:cc:dd:ee fw_setenv bootcmd "bootm 0x9f050000 || bootm 0x9fe80000" 9. Perform sysupgrade with squashfs-sysupgrade image 10. Wait ~150 seconds to complete flashing And this commit includes small fix; BHR-4GRV2 has QCA9557 as a SoC, not QCA9558. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/tiny.mk')
-rw-r--r--target/linux/ath79/image/tiny.mk19
1 files changed, 0 insertions, 19 deletions
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 4dda24edac..bf7a5e140b 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -1,24 +1,5 @@
include ./common-buffalo.mk
-DEVICE_VARS += ROOTFS_SIZE
-
-define Device/buffalo_bhr-4grv2
- ATH_SOC := qca9558
- DEVICE_TITLE := Buffalo BHR-4GRV2
- BOARDNAME := BHR-4GRV2
- ROOTFS_SIZE := 14528k
- KERNEL_SIZE := 1472k
- IMAGE_SIZE := 16000k
- IMAGES += factory.bin
- IMAGE/sysupgrade.bin := \
- append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | \
- append-kernel | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.bin := append-kernel | \
- pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | mkbuffaloimg
- SUPPORTED_DEVICES += bhr-4grv2
-endef
-TARGET_DEVICES += buffalo_bhr-4grv2
-
define Device/buffalo_whr-g301n
ATH_SOC := ar7240
DEVICE_TITLE := Buffalo WHR-G301N