aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny.mk
diff options
context:
space:
mode:
authorYuheiOKAWA <tochiro.srchack@gmail.com>2018-10-05 01:08:51 +0900
committerMathias Kresin <dev@kresin.me>2018-10-28 10:59:14 +0100
commit27eae6597e5f1570f2f0a8584907b077e724a0e1 (patch)
tree91865cc6958f3977acf93dd1918ce6e7b0a0c853 /target/linux/ath79/image/tiny.mk
parent23f9b2d9a981c61b7166557febde31778d13b86f (diff)
downloadupstream-27eae6597e5f1570f2f0a8584907b077e724a0e1.tar.gz
upstream-27eae6597e5f1570f2f0a8584907b077e724a0e1.tar.bz2
upstream-27eae6597e5f1570f2f0a8584907b077e724a0e1.zip
ath79: add support for PQI Air Pen
SoC: AR9330 (or AR9331 revision?) Ethernet x1, Wireless 2.4G, uSD card slot x1. USB Power, include Li-Po Battery. Flash 8MiB. (factory is dual image) 1. write image is use half 4MiB size from factory. write initramfs image to mtd6 and mtd7. 2. change next boot setting. next is mtd6 boot. echo -ne "\x01" | dd of=/dev/mtdblock8 conv=notrunc bs=1 count=1 seek=0 3. rewrite sysupgrade image. change next boot setting. next is mtd4. echo -ne "\x00" | dd of=/dev/mtdblock8 conv=notrunc bs=1 count=1 seek=0 OEM mtd. dev: size erasesize name mtd0: 00040000 00010000 "u-boot" mtd1: 00010000 00010000 "u-boot-env" mtd2: 00010000 00010000 "ART" mtd3: 00010000 00010000 "NVRAM" mtd4: 00140000 00010000 "uImage" mtd5: 00280000 00010000 "rootfs" mtd6: 00140000 00010000 "uImage2" mtd7: 00280000 00010000 "rootfs2" mtd8: 00010000 00010000 "CONF" Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/tiny.mk')
-rw-r--r--target/linux/ath79/image/tiny.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index bc738c2f77..4dda24edac 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -30,3 +30,12 @@ define Device/buffalo_whr-g301n
SUPPORTED_DEVICES += whr-g301n
endef
TARGET_DEVICES += buffalo_whr-g301n
+
+define Device/pqi_air-pen
+ ATH_SOC := ar9330
+ DEVICE_TITLE := PQI Air-Pen
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ IMAGE_SIZE := 7680k
+ SUPPORTED_DEVICES += pqi-air-pen
+endef
+TARGET_DEVICES += pqi_air-pen