aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorChristian Buschau <christian.buschau@mailbox.org>2020-02-05 22:05:39 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-11 14:31:05 +0100
commitfb99ac6807f29eb5fe50271eff711e7415038731 (patch)
treef8d1abd25c780bad4d2d270823cf7ad325eae95e /target/linux/ath79/image/tiny-tp-link.mk
parent273e00c4a506c076dddfc51c3c00d4523496f5f4 (diff)
downloadupstream-fb99ac6807f29eb5fe50271eff711e7415038731.tar.gz
upstream-fb99ac6807f29eb5fe50271eff711e7415038731.tar.bz2
upstream-fb99ac6807f29eb5fe50271eff711e7415038731.zip
ath79: add support for TP-Link TL-WA830RE v1
This ports support for the TL-WA830RE v1 range extender from ar71xx to ath79. Specifications: - SOC: Atheros AR7240 - CPU: 400MHz - Flash: 4 MiB (Spansion S25FL032P) - RAM: 32 MiB (Zentel A3S56D40FTP-G5) - WLAN: Atheros AR9280 bgn 2x2 - Ethernet: 1 port (100M) Flash instructions: - install from u-boot with tftp (requires serial access) > setenv ipaddr a.b.c.d > setenv serverip e.f.g.h > tftpboot 0x80000000 \ openwrt-ath79-tiny-tplink_tl-wa830re-v1-squashfs-factory.bin > erase 0x9f020000 +0x3c0000 > cp.b 0x80000000 0x9f020000 0x3c0000 > bootm 0x9f020000 - flash factory image from OEM WebUI - sysupgrade from ar71xx image The device seems to be a clone of the following devices not yet added to ath79: - tl-wa701nd-v1 - tl-wa730re-v1 - tl-wa801nd-v1 - tl-wa901nd-v1 Signed-off-by: Christian Buschau <christian.buschau@mailbox.org> [make use of ar7240_tplink.dtsi, add note about clones] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 2107e47cc3..787ac055ba 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -66,6 +66,16 @@ define Device/tplink_tl-mr3420-v2
endef
TARGET_DEVICES += tplink_tl-mr3420-v2
+define Device/tplink_tl-wa830re-v1
+ $(Device/tplink-4m)
+ SOC := ar7240
+ DEVICE_MODEL := TL-WA830RE
+ DEVICE_VARIANT := v1
+ TPLINK_HWID := 0x08300010
+ SUPPORTED_DEVICES += tl-wa901nd
+endef
+TARGET_DEVICES += tplink_tl-wa830re-v1
+
define Device/tplink_tl-wa850re-v1
$(Device/tplink-4mlzma)
SOC := ar9341