aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorLim Guo Wei <limguowei@gmail.com>2019-08-12 15:54:11 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-08-17 23:52:34 +0800
commite7ab1b517397fdf6613f4682b7a752649841f7cd (patch)
treecfe098a3a24b803b9e90f44c67aa5282ec43fd8c /target/linux/ath79/image/tiny-tp-link.mk
parent2ada2a5e5bc02a5e7b3feefbee4dec0c4c355f5b (diff)
downloadupstream-e7ab1b517397fdf6613f4682b7a752649841f7cd.tar.gz
upstream-e7ab1b517397fdf6613f4682b7a752649841f7cd.tar.bz2
upstream-e7ab1b517397fdf6613f4682b7a752649841f7cd.zip
ath79: migrate TP-Link TL-MR3420v2 to ath79
Specifications: - SoC: ar9341 - RAM: 32M - Flash: 4M - Ethernet: 5x FE ports - WiFi: ar9341-wmac Flash instruction: Upload generated factory firmware on vendor's web interface. This changes the key assignment compared to ar71xx support of this device, since of the two keys on the device one is used as combined Reset/WPS and the second one as WiFi on/off button. Despite, the reset button required GPIO_ACTIVE_HIGH to work correctly. Signed-off-by: Lim Guo Wei <limguowei@gmail.com> [redo commit message] Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index a2d598fb77..71d165fdc2 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -55,6 +55,17 @@ define Device/tplink_tl-mr3420-v1
endef
TARGET_DEVICES += tplink_tl-mr3420-v1
+define Device/tplink_tl-mr3420-v2
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9341
+ DEVICE_MODEL := TL-MR3420
+ DEVICE_VARIANT := v2
+ TPLINK_HWID := 0x34200002
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
+ SUPPORTED_DEVICES += tl-mr3420-v2
+endef
+TARGET_DEVICES += tplink_tl-mr3420-v2
+
define Device/tplink_tl-wa901nd-v2
$(Device/tplink-4m)
ATH_SOC := ar9132