aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-16 14:41:44 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-22 23:52:51 +0100
commita66a1eb9c5f07095d8ed266b733b379bc9a8e8d4 (patch)
tree5d98c877235e259af86f000820644469dc4fd201 /target/linux/ath79/image/tiny-tp-link.mk
parentb2102be8a54ad14043035527d8ed33f4611f1553 (diff)
downloadupstream-a66a1eb9c5f07095d8ed266b733b379bc9a8e8d4.tar.gz
upstream-a66a1eb9c5f07095d8ed266b733b379bc9a8e8d4.tar.bz2
upstream-a66a1eb9c5f07095d8ed266b733b379bc9a8e8d4.zip
ath79: add support for TP-Link TL-WA850RE v2
TP-Link TL-WA850RE v2 is a wall-plug N300 Wi-Fi range extender, based on Qualcomm/Atheros QCA9533 v2. Short specification: - 550/391/195 MHz (CPU/DDR/AHB) - 1x 10/100 Mbps Ethernet - 32 MB of RAM (DDR1) - 4 MB of FLASH - 2T2R 2.4 GHz - 2x internal antennas (embedded on PCB) - 9x LED (all can be turned off with GPIO15), 2x button - UART (J3) header on PCB Flash instruction: use "factory" image directly in vendor GUI. Warning: this device does not include any kind of recovery mechanism in the bootloader and disassembling process is not trivial. You can access vendor firmware over serial line using: - login: root - password: sohoadmin Stock firmware uses label MAC address for WiFi and same with local bit set for ethernet. Since this is difficult to reproduce with the toolset of OpenWrt, we just keep both ethernet and WiFi to the same address here. This is the first tiny device with tplink-safeloader in ath79. Firmware partition is only 3648k and thus even smaller than for the tplink-4m(lzma) devices. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 3c15f843a9..e5208530d6 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -77,6 +77,20 @@ define Device/tplink_tl-wa850re-v1
endef
TARGET_DEVICES += tplink_tl-wa850re-v1
+define Device/tplink_tl-wa850re-v2
+ $(Device/tplink-safeloader)
+ SOC := qca9533
+ IMAGE_SIZE := 3648k
+ DEVICE_MODEL := TL-WA850RE
+ DEVICE_VARIANT := v2
+ TPLINK_BOARD_ID := TLWA850REV2
+ TPLINK_HWID := 0x08500002
+ TPLINK_HWREV := 0x0
+ DEVICE_PACKAGES := rssileds
+ SUPPORTED_DEVICES += tl-wa850re-v2
+endef
+TARGET_DEVICES += tplink_tl-wa850re-v2
+
define Device/tplink_tl-wa901nd-v2
$(Device/tplink-4m)
SOC := ar9132