aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorAdoal Xu <adoalxu@gmail.com>2018-06-04 01:04:51 +0800
committerJohn Crispin <john@phrozen.org>2018-06-08 09:56:15 +0200
commita51078f7354fac9e31f6956cbddc77aaef02c67b (patch)
treea6ffca250603144bdcef6e49f1205788f2857b6a /target/linux/ath79/image/tiny-tp-link.mk
parent4f6320704f7e37368a1dae2deba767a73b3bf121 (diff)
downloadupstream-a51078f7354fac9e31f6956cbddc77aaef02c67b.tar.gz
upstream-a51078f7354fac9e31f6956cbddc77aaef02c67b.tar.bz2
upstream-a51078f7354fac9e31f6956cbddc77aaef02c67b.zip
ath79: add TP-Link TL-MR10U port
Signed-off-by: Adoal Xu <adoalxu@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index e6d5feefc5..f92c7d9644 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -1,6 +1,16 @@
include ./common-tp-link.mk
+define Device/tl-mr10u
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9331
+ DEVICE_TITLE := TP-Link TL-MR10U
+ DEVICE_PACKAGES := kmod-usb-chipidea2
+ TPLINK_HWID := 0x00100101
+ SUPPORTED_DEVICES := tplink,tl-mr10u tl-mr10u
+endef
+TARGET_DEVICES += tl-mr10u
+
define Device/tl-wr703n
$(Device/tplink-4mlzma)
ATH_SOC := ar9331