aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2019-01-20 23:30:27 +0800
committerPetr Štetiar <ynezz@true.cz>2019-03-24 01:44:27 +0100
commit8de907c441db8a4aae746f44ee2c4651225d389f (patch)
tree74780aaa596e68f0595f21d525891ae4c37cf159 /target/linux/ath79/image/tiny-tp-link.mk
parent3d93b35f039de86830565420968715b300066475 (diff)
downloadupstream-8de907c441db8a4aae746f44ee2c4651225d389f.tar.gz
upstream-8de907c441db8a4aae746f44ee2c4651225d389f.tar.bz2
upstream-8de907c441db8a4aae746f44ee2c4651225d389f.zip
ath79: add support for TP-Link TL-WR941N v7 (CN)
This adds support for the Chinese version of TL-WR941N v7. It uses QCA9558+AR8236 while the international version uses TP9343 instead. Specification: - SoC: Qualcomm Atheros QCA9558 - Flash: 4 MB - RAM: 64 MB - Ethernet: Atheros AR8236 with 5 FE ports Flash instruction: Upload the generated factory firmware on web interface. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 8847ca57e5..fb8ab75cb1 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -180,3 +180,11 @@ define Device/tplink_tl-wr941-v4
TPLINK_HWID := 0x09410004
endef
TARGET_DEVICES += tplink_tl-wr941-v4
+
+define Device/tplink_tl-wr941n-v7-cn
+ $(Device/tplink-4mlzma)
+ ATH_SOC := qca9558
+ DEVICE_TITLE := TP-Link TL-WR941N v7 (CN)
+ TPLINK_HWID := 0x09410007
+endef
+TARGET_DEVICES += tplink_tl-wr941n-v7-cn