aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-09 14:51:07 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-22 17:18:55 +0100
commit6eaea3a8ba6154674058396c728494aa911ed7f1 (patch)
treeeb7b0be8e51f66c501b76195cfc24b2a2f936468 /target/linux/ath79/image/tiny-tp-link.mk
parent3d6c571083d324567ec1a9c4fcac1712e7d2e42a (diff)
downloadupstream-6eaea3a8ba6154674058396c728494aa911ed7f1.tar.gz
upstream-6eaea3a8ba6154674058396c728494aa911ed7f1.tar.bz2
upstream-6eaea3a8ba6154674058396c728494aa911ed7f1.zip
ath79: add support for TP-Link TL-WA850RE v1
This ports support for the TL-WA850RE v1 range extender from ar71xx to ath79. Specifications: Board: AP123 / AR9341 rev. 3 Flash/RAM: 4/32 MiB CPU: 535 MHz WiFi: 2.4 GHz b/g/n Ethernet: 1 port (100M) Flashing instructions: Upload the factory image via the vendor firmware upgrade option. Recovery: Note that this device does not provide TFTP via ethernet like many other TP-Link devices do. You will have to open the case if you require recovery beyond failsafe. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 070ede9721..3c15f843a9 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -66,6 +66,17 @@ define Device/tplink_tl-mr3420-v2
endef
TARGET_DEVICES += tplink_tl-mr3420-v2
+define Device/tplink_tl-wa850re-v1
+ $(Device/tplink-4mlzma)
+ SOC := ar9341
+ DEVICE_MODEL := TL-WA850RE
+ DEVICE_VARIANT := v1
+ TPLINK_HWID := 0x08500001
+ DEVICE_PACKAGES := rssileds
+ SUPPORTED_DEVICES += tl-wa850re
+endef
+TARGET_DEVICES += tplink_tl-wa850re-v1
+
define Device/tplink_tl-wa901nd-v2
$(Device/tplink-4m)
SOC := ar9132