aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorRocco Folino <rocco@folino.io>2018-07-02 07:02:56 +0200
committerJohn Crispin <john@phrozen.org>2018-07-02 07:03:21 +0200
commit4ff019722cf9663c3f2645927041b0a248ff1d0b (patch)
tree6495747d57dcb6778493fa39be22375ac6349e22 /target/linux/ath79/image/tiny-tp-link.mk
parent9b575288ebdda335502219528c40d26b8e339376 (diff)
downloadupstream-4ff019722cf9663c3f2645927041b0a248ff1d0b.tar.gz
upstream-4ff019722cf9663c3f2645927041b0a248ff1d0b.tar.bz2
upstream-4ff019722cf9663c3f2645927041b0a248ff1d0b.zip
ath79: port TP-Link TL-WR741ND v4 and TL-WR740ND v4
This patch ports the TP-Link TL-WR741ND v4 and TL-WR740ND v4 to the ath79 target. Because the two devices share the same hw layout, this patch adds a common .dtsi which is included by the two .dts. Signed-off-by: Rocco Folino <rocco@folino.io>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 0004eb2018..fa937b6bd5 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -60,6 +60,24 @@ define Device/tl-wr740n-v2
endef
TARGET_DEVICES += tl-wr740n-v2
+define Device/tl-wr740nd-v4
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9331
+ DEVICE_TITLE := TP-LINK TL-WR740N/ND v4
+ TPLINK_HWID := 0x07400004
+ SUPPORTED_DEVICES := tplink,tl-wr740n-v4 tl-wr740n-v4
+endef
+TARGET_DEVICES += tl-wr740nd-v4
+
+define Device/tl-wr741nd-v4
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9331
+ DEVICE_TITLE := TP-LINK TL-WR741N/ND v4
+ TPLINK_HWID := 0x07410004
+ SUPPORTED_DEVICES := tplink,tl-wr741n-v4 tl-wr741n-v4
+endef
+TARGET_DEVICES += tl-wr741nd-v4
+
define Device/tl-wr841-v7
$(Device/tplink-4m)
ATH_SOC := ar7241