aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-14 15:38:55 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-21 13:55:33 +0100
commit2f1cc5c3d5e35d6aa76e794e3d5b4f5856cd38bc (patch)
tree5eeefa0c3025f54eea0260cf9b008c22867e0bb4 /target/linux/ath79/image/tiny-tp-link.mk
parent1df4f5cf962ae869c10bfb11b28d94463a769abc (diff)
downloadupstream-2f1cc5c3d5e35d6aa76e794e3d5b4f5856cd38bc.tar.gz
upstream-2f1cc5c3d5e35d6aa76e794e3d5b4f5856cd38bc.tar.bz2
upstream-2f1cc5c3d5e35d6aa76e794e3d5b4f5856cd38bc.zip
ath79: add support for TP-Link TL-WA701ND/730RE/801ND/901ND v1
This adds support for the various clones of the TL-WA830RE recently supported in fb99ac6807f2 ("ath79: add support for TP-Link TL-WA830RE v1"): - tplink,tl-wa701nd-v1 - tplink,tl-wa730re-v1 - tplink,tl-wa801nd-v1 - tplink,tl-wa830re-v1 (already supported) - tplink,tl-wa901nd-v1 Since these devices are 100%-clones in ar71xx, this patch adds all of them without run-testing (as this has been done for TL-WA830RE v1). Specifications: - SOC: Atheros AR7240 - CPU: 400MHz - Flash: 4 MiB (Spansion S25FL032P) - RAM: 32 MiB (Zentel A3S56D40FTP-G5) - WLAN: Atheros AR9280 bgn 2x2 - Ethernet: 1 port (100M) Flash instructions: - install from u-boot with tftp (requires serial access) > setenv ipaddr a.b.c.d > setenv serverip e.f.g.h > tftpboot 0x80000000 \ openwrt-ath79-tiny-tplink_tl-waxxxxx-v1-squashfs-factory.bin > erase 0x9f020000 +0x3c0000 > cp.b 0x80000000 0x9f020000 0x3c0000 > bootm 0x9f020000 - flash factory image from OEM WebUI - sysupgrade from ar71xx image Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index dde1088f54..29fdfec1e5 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -66,6 +66,36 @@ define Device/tplink_tl-mr3420-v2
endef
TARGET_DEVICES += tplink_tl-mr3420-v2
+define Device/tplink_tl-wa701nd-v1
+ $(Device/tplink-4m)
+ SOC := ar7240
+ DEVICE_MODEL := TL-WA701ND
+ DEVICE_VARIANT := v1
+ TPLINK_HWID := 0x07010001
+ SUPPORTED_DEVICES += tl-wa901nd
+endef
+TARGET_DEVICES += tplink_tl-wa701nd-v1
+
+define Device/tplink_tl-wa730re-v1
+ $(Device/tplink-4m)
+ SOC := ar7240
+ DEVICE_MODEL := TL-WA730RE
+ DEVICE_VARIANT := v1
+ TPLINK_HWID := 0x07300001
+ SUPPORTED_DEVICES += tl-wa901nd
+endef
+TARGET_DEVICES += tplink_tl-wa730re-v1
+
+define Device/tplink_tl-wa801nd-v1
+ $(Device/tplink-4m)
+ SOC := ar7240
+ DEVICE_MODEL := TL-WA801ND
+ DEVICE_VARIANT := v1
+ TPLINK_HWID := 0x08010001
+ SUPPORTED_DEVICES += tl-wa901nd
+endef
+TARGET_DEVICES += tplink_tl-wa801nd-v1
+
define Device/tplink_tl-wa830re-v1
$(Device/tplink-4m)
SOC := ar7240
@@ -100,6 +130,16 @@ define Device/tplink_tl-wa850re-v2
endef
TARGET_DEVICES += tplink_tl-wa850re-v2
+define Device/tplink_tl-wa901nd-v1
+ $(Device/tplink-4m)
+ SOC := ar7240
+ DEVICE_MODEL := TL-WA901ND
+ DEVICE_VARIANT := v1
+ TPLINK_HWID := 0x09010001
+ SUPPORTED_DEVICES += tl-wa901nd
+endef
+TARGET_DEVICES += tplink_tl-wa901nd-v1
+
define Device/tplink_tl-wa901nd-v2
$(Device/tplink-4m)
SOC := ar9132