aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 13:17:44 +0800
committerMathias Kresin <dev@kresin.me>2018-08-08 08:11:11 +0200
commit1edba538a97fe8a17a388a43506fe562533b02ed (patch)
tree35782415e495f705636207a10046412607ffd992 /target/linux/ath79/image/tiny-tp-link.mk
parent55ff2951eac8fd86c91b9673395325e393e357ac (diff)
downloadupstream-1edba538a97fe8a17a388a43506fe562533b02ed.tar.gz
upstream-1edba538a97fe8a17a388a43506fe562533b02ed.tar.bz2
upstream-1edba538a97fe8a17a388a43506fe562533b02ed.zip
ath79: Fix led nodes for TL-WR740N v2 and add its clones
This patch did the following things: 1. Separate ath9k-leds out of gpio leds so that all other leds will work before ath9k loded (e.g. during preinit/init stage). 2. Rename wps led to qss since that's how TP-Link mark it. 3. Rename LED prefix to tp-link because that dts is shared by many devices. 4. Rename to wr740n-v1 because v1 is the first and v2 just use the fw of v1. (This will require a forced sysupgrade if you comes from the previous wr740n v2 image.) 5. Remove SUPPORTED_DEVICES. (tl-wr740n-v2 doesn't exist anywhere so it's useless.) 6. Add all WR741ND v1 clones found in ar71xx. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk47
1 files changed, 43 insertions, 4 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 44dd2700a5..6aefd9e14c 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -51,14 +51,21 @@ define Device/tplink_tl-wr703n
endef
TARGET_DEVICES += tplink_tl-wr703n
-define Device/tplink_tl-wr740n-v2
+define Device/tplink_tl-wr740n-v1
$(Device/tplink-4m)
ATH_SOC := ar7240
- DEVICE_TITLE := TP-Link TL-WR740N/ND v2
+ DEVICE_TITLE := TP-Link TL-WR740N v1/v2
TPLINK_HWID := 0x07400001
- SUPPORTED_DEVICES += tl-wr740n-v2
endef
-TARGET_DEVICES += tplink_tl-wr740n-v2
+TARGET_DEVICES += tplink_tl-wr740n-v1
+
+define Device/tplink_tl-wr740n-v3
+ $(Device/tplink-4m)
+ ATH_SOC := ar7240
+ DEVICE_TITLE := TP-Link TL-WR740N v3
+ TPLINK_HWID := 0x07400003
+endef
+TARGET_DEVICES += tplink_tl-wr740n-v3
define Device/tplink_tl-wr740nd-v4
$(Device/tplink-4mlzma)
@@ -69,6 +76,14 @@ define Device/tplink_tl-wr740nd-v4
endef
TARGET_DEVICES += tplink_tl-wr740nd-v4
+define Device/tplink_tl-wr741-v1
+ $(Device/tplink-4m)
+ ATH_SOC := ar7240
+ DEVICE_TITLE := TP-Link TL-WR741N/ND v1/v2
+ TPLINK_HWID := 0x07410001
+endef
+TARGET_DEVICES += tplink_tl-wr741-v1
+
define Device/tplink_tl-wr741nd-v4
$(Device/tplink-4mlzma)
ATH_SOC := ar9331
@@ -78,6 +93,22 @@ define Device/tplink_tl-wr741nd-v4
endef
TARGET_DEVICES += tplink_tl-wr741nd-v4
+define Device/tplink_tl-wr743nd-v1
+ $(Device/tplink-4m)
+ ATH_SOC := ar7240
+ DEVICE_TITLE := TP-Link TL-WR743ND v1
+ TPLINK_HWID := 0x07430001
+endef
+TARGET_DEVICES += tplink_tl-wr743nd-v1
+
+define Device/tplink_tl-wr841-v5
+ $(Device/tplink-4m)
+ ATH_SOC := ar7240
+ DEVICE_TITLE := TP-Link TL-WR841N/ND v5/v6
+ TPLINK_HWID := 0x08410005
+endef
+TARGET_DEVICES += tplink_tl-wr841-v5
+
define Device/tplink_tl-wr841-v7
$(Device/tplink-4m)
ATH_SOC := ar7241
@@ -95,3 +126,11 @@ define Device/tplink_tl-wr841-v9
SUPPORTED_DEVICES += tl-wr841n-v9
endef
TARGET_DEVICES += tplink_tl-wr841-v9
+
+define Device/tplink_tl-wr941-v4
+ $(Device/tplink-4m)
+ ATH_SOC := ar7240
+ DEVICE_TITLE := TP-Link TL-WR941N/ND v4
+ TPLINK_HWID := 0x09410004
+endef
+TARGET_DEVICES += tplink_tl-wr941-v4