aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 15:42:48 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 16:09:58 +0100
commit07ce940b77e6aceb095b0a16dda41e190dfc5b87 (patch)
tree82ab93a5bfa55711ab5ab5b597cb8915ef4b8f5e /target/linux/ath79/image/tiny-tp-link.mk
parent071a6372762d289b2fa5a8d1a138eff944c93c9e (diff)
downloadupstream-07ce940b77e6aceb095b0a16dda41e190dfc5b87.tar.gz
upstream-07ce940b77e6aceb095b0a16dda41e190dfc5b87.tar.bz2
upstream-07ce940b77e6aceb095b0a16dda41e190dfc5b87.zip
ath79: fix SUPPORTED_DEVICES not matching ar71xx board names
Based on a script for comparison, this fixes (hopefully) all errors in SUPPORTED_DEVICES for ar71xx->ath79 upgrade. Devices where old string is removed as the device does not exist in ar71xx: - dlink_dir-859-a1 - tplink_archer-a7-v5 - tplink_cpe510-v3 Devices where string is changed because it did not match the board name in ar71xx: - tplink_tl-mr3220-v1 - tplink_tl-mr3420-v1 - tplink_tl-wr2543-v1 - tplink_tl-wr741nd-v4 - tplink_tl-wr841-v7 - ubnt_unifiac-mesh - ubnt_unifiac-mesh-pro - ubnt_unifiac-pro For this device, the correct string could not be found, but we could not determine the correct one. Thus, the string is removed for now: - tplink_tl-wr740n-v4 The script for checking this is quite simple (note that newer entries, i.e. ath79->ath79 upgrade, are displayed as missing): newpath=target/linux/ath79/image/ oldpath=target/linux/ar71xx/base-files/lib/ar71xx.sh for s in $(grep -roh "SUPPORTED_DEVICES.*" $newpath | sed 's/SUPPORTED_DEVICES *.= *//'); do found="Missing" grep -q -r "\"$s\"" $oldpath && found="Found" echo "$s: $found." done The errors might be filtered by appending 'grep "Missing"' to the script. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index e5208530d6..2107e47cc3 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -40,7 +40,7 @@ define Device/tplink_tl-mr3220-v1
DEVICE_VARIANT := v1
TPLINK_HWID := 0x32200001
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
- SUPPORTED_DEVICES += tl-mr3220-v1
+ SUPPORTED_DEVICES += tl-mr3220
endef
TARGET_DEVICES += tplink_tl-mr3220-v1
@@ -51,7 +51,7 @@ define Device/tplink_tl-mr3420-v1
DEVICE_VARIANT := v1
TPLINK_HWID := 0x34200001
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
- SUPPORTED_DEVICES += tl-mr3420-v1
+ SUPPORTED_DEVICES += tl-mr3420
endef
TARGET_DEVICES += tplink_tl-mr3420-v1
@@ -134,7 +134,6 @@ define Device/tplink_tl-wr740n-v4
DEVICE_MODEL := TL-WR740N
DEVICE_VARIANT := v4
TPLINK_HWID := 0x07400004
- SUPPORTED_DEVICES += tl-wr740n-v4
endef
TARGET_DEVICES += tplink_tl-wr740n-v4
@@ -153,7 +152,7 @@ define Device/tplink_tl-wr741nd-v4
DEVICE_MODEL := TL-WR741N/ND
DEVICE_VARIANT := v4
TPLINK_HWID := 0x07410004
- SUPPORTED_DEVICES += tl-wr741n-v4
+ SUPPORTED_DEVICES += tl-wr741nd-v4
endef
TARGET_DEVICES += tplink_tl-wr741nd-v4
@@ -181,7 +180,7 @@ define Device/tplink_tl-wr841-v7
DEVICE_MODEL := TL-WR841N/ND
DEVICE_VARIANT := v7
TPLINK_HWID := 0x08410007
- SUPPORTED_DEVICES += tl-wr841-v7
+ SUPPORTED_DEVICES += tl-wr841n-v7
endef
TARGET_DEVICES += tplink_tl-wr841-v7