aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-netgear.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-06-16 21:34:46 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-04 15:50:17 +0200
commit8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5 (patch)
treeb58ad085eae892fa35cb6e7a8f0b09373b5c4d3e /target/linux/ath79/image/tiny-netgear.mk
parentcb689f2723b40c96426ac69f1478530ff1d48368 (diff)
downloadupstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.tar.gz
upstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.tar.bz2
upstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.zip
ath79: split DEVICE_TITLE in multiple variables
This allows the definition of DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT. All three are merged together to look the same as the current DEVICE_TITLE. Also, if DEVICE_TITLE is set it's directly used as a *fallback* for devices which weren't upgraded yet. This is based on the work of @sudhanshu16. The motivation is to create JSON files based on provided metadata, needing clear differentiation between vendor, model and revision. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux/ath79/image/tiny-netgear.mk')
-rw-r--r--target/linux/ath79/image/tiny-netgear.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/ath79/image/tiny-netgear.mk b/target/linux/ath79/image/tiny-netgear.mk
index 42d6cab8bd..f353bc70bf 100644
--- a/target/linux/ath79/image/tiny-netgear.mk
+++ b/target/linux/ath79/image/tiny-netgear.mk
@@ -11,7 +11,9 @@ endef
define Device/netgear_wnr612-v2
$(Device/netgear_ar7240)
- DEVICE_TITLE := Netgear WNR612v2
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := WNR612
+ DEVICE_VARIANT := v2
DEVICE_DTS := ar7240_netgear_wnr612-v2
NETGEAR_BOARD_ID := REALWNR612V2
SUPPORTED_DEVICES += wnr612-v2
@@ -20,7 +22,8 @@ TARGET_DEVICES += netgear_wnr612-v2
define Device/on_n150r
$(Device/netgear_ar7240)
- DEVICE_TITLE := ON Network N150R
+ DEVICE_VENDOR := On Networks
+ DEVICE_MODEL := N150R
NETGEAR_BOARD_ID := N150R
SUPPORTED_DEVICES += n150r
endef