aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-netgear.mk
diff options
context:
space:
mode:
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>2019-10-16 12:42:44 +0200
committerJohn Crispin <john@phrozen.org>2019-10-21 13:15:46 +0200
commit09f46c6b541b2db1b16d03176f10f7ff589713c4 (patch)
tree61fa1b5208d1a0822e9f0eaeb0085b10886a5d24 /target/linux/ath79/image/tiny-netgear.mk
parent12719ce37a0782a2e7b816020cdfca1973d5bc01 (diff)
downloadupstream-09f46c6b541b2db1b16d03176f10f7ff589713c4.tar.gz
upstream-09f46c6b541b2db1b16d03176f10f7ff589713c4.tar.bz2
upstream-09f46c6b541b2db1b16d03176f10f7ff589713c4.zip
ath79: add support for Netgear WNR1000 v2
This patch adds ath79 support for Netgear WNR1000v2. Router was previously supported by ar71xx target only. Note: this is a 4_32 device with limited upgrade capabilities. Specification ============= * Description: Netgear WNR1000 v2 * Loader: U-boot * SOC: Atheros AR7240 (340 MHz) * RAM: 32 MiB * Flash: 4 MiB (SPI NOR) - U-boot binary: 256 KiB - U-boot environment: 64 KiB - Firmware: 3712 KiB - ART: 64 KiB * Ethernet: 4 x 10/100 LAN + 1 x 10/100 WAN * Wireless: 2.4 GHz b/g/n (Atheros AR9285) * USB: no * Buttons: - Reset - WiFi (rfkill) - WPS * LEDs: - Power (amber/green) - WAN (amber/green) - WLAN (blue) - 4 x LAN (amber/green) - WPS (green) * UART: 4-pin connector JP2, 3.3V (Vcc, TX, RX, GND), 115200 8N1 * Power supply: DC 12V 1A * MAC addresses: LAN on case label, WAN +1, WLAN +2 Installation ============ * TFTP recovery * TFTP via U-boot prompt * sysupgrade * Web interface Test build configuration ======================== CONFIG_TARGET_ath79=y CONFIG_TARGET_ath79_tiny=y CONFIG_TARGET_ath79_tiny_DEVICE_netgear_wnr1000-v2=y CONFIG_ALL_KMODS=y CONFIG_DEVEL=y CONFIG_CCACHE=y CONFIG_COLLECT_KERNEL_DEBUG=y CONFIG_IMAGEOPT=y CONFIG_KERNEL_DEBUG_INFO=y CONFIG_KERNEL_DEBUG_KERNEL=y Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Diffstat (limited to 'target/linux/ath79/image/tiny-netgear.mk')
-rw-r--r--target/linux/ath79/image/tiny-netgear.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-netgear.mk b/target/linux/ath79/image/tiny-netgear.mk
index b5fed1b88b..0df19390bb 100644
--- a/target/linux/ath79/image/tiny-netgear.mk
+++ b/target/linux/ath79/image/tiny-netgear.mk
@@ -28,6 +28,18 @@ define Device/on_n150r
endef
TARGET_DEVICES += on_n150r
+define Device/netgear_wnr1000-v2
+ ATH_SOC := ar7240
+ DEVICE_MODEL := WNR1000
+ DEVICE_VARIANT := v2
+ NETGEAR_KERNEL_MAGIC := 0x31303031
+ IMAGE_SIZE := 3712k
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
+ SUPPORTED_DEVICES += wnr1000-v2
+ $(Device/netgear_ath79)
+endef
+TARGET_DEVICES += netgear_wnr1000-v2
+
define Device/netgear_wnr2000-v3
ATH_SOC := ar7241
DEVICE_MODEL := WNR2000