aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/nand.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-01-08 20:18:56 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-01-11 10:37:04 +0800
commitb97247c2e9cd528206dbe5c55055bd913230eba4 (patch)
tree070e8129a34257adb0898ef0c44b523165db8cc2 /target/linux/ath79/image/nand.mk
parent7936cb94a930dcff0d30d294efb693648e1768ff (diff)
downloadupstream-b97247c2e9cd528206dbe5c55055bd913230eba4.tar.gz
upstream-b97247c2e9cd528206dbe5c55055bd913230eba4.tar.bz2
upstream-b97247c2e9cd528206dbe5c55055bd913230eba4.zip
ath79: gl-ar750s: reduce kernel size to 2M in image Makefile
u-boot splits nand factory firmware at 2M offset, flash the first part as kernel into spi nor and the other part as ubi into nand flash. With previous commit increasing kernel size to 4M, generated factory firmware is broken because ubi is at 4M offset. This commit reduces kernel size definition to 2M in image Makefile, producing proper factory image. Partition size in dts is kept unchanged so that sysupgrade to a firmware with 2M+ kernel still works. Fixes: b496a2294c ("ath79: GL-AR750S: provide NAND support; increase kernel to 4 MB") Reported-by: Jeff Kletsky <git-commits@allycomm.com> Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/nand.mk')
-rw-r--r--target/linux/ath79/image/nand.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index c6a1441ed9..cc775d52b6 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -82,7 +82,7 @@ define Device/glinet_gl-ar750s-common
DEVICE_MODEL := GL-AR750S
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct kmod-usb2 \
kmod-usb-storage block-mount
- KERNEL_SIZE := 4096k
+ KERNEL_SIZE := 2048k
IMAGE_SIZE := 16000k
PAGESIZE := 2048
VID_HDR_OFFSET := 2048