aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/nand.mk
diff options
context:
space:
mode:
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>2019-12-22 21:55:54 +0100
committerJohn Crispin <john@phrozen.org>2020-01-15 20:56:05 +0100
commita736f394323689dbbfbe548f93e6aa620016a64a (patch)
tree8f479c61421465bf7201d8e4e096dfbb5cf91e70 /target/linux/ath79/image/nand.mk
parent37a36a588a015c5f9e57c80c75670cf993955f24 (diff)
downloadupstream-a736f394323689dbbfbe548f93e6aa620016a64a.tar.gz
upstream-a736f394323689dbbfbe548f93e6aa620016a64a.tar.bz2
upstream-a736f394323689dbbfbe548f93e6aa620016a64a.zip
ath79: add support for Netgear WNDR4500 v3
This patch introduces support for Netgear WNDR4500v3. Router is very similar to WNDR4300v2 and is based on the same PCB. Information gathered from various Internet sources (including https://patchwork.ozlabs.org/patch/809227/) shows following differences to WNDR4300v2: * two USB 2.0 ports with separate LEDs * USB LEDs soldered to secondary pads * WPS and RFKILL buttons soldered to secondary pads * described as N900 device with 3x3:3 MIMO for 2.4GHz radio * power supply requirement is DC 12V 2.5A * vendor HW ID suffix differs in one digit * bigger chassis Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Diffstat (limited to 'target/linux/ath79/image/nand.mk')
-rw-r--r--target/linux/ath79/image/nand.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index d5213523e4..f6929cd88e 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -165,6 +165,17 @@ define Device/netgear_wndr4300-v2
endef
TARGET_DEVICES += netgear_wndr4300-v2
+define Device/netgear_wndr4500-v3
+ SOC := qca9563
+ DEVICE_MODEL := WNDR4500
+ DEVICE_VARIANT := v3
+ NETGEAR_KERNEL_MAGIC := 0x27051956
+ NETGEAR_BOARD_ID := WNDR4500series
+ NETGEAR_HW_ID := 29764821+2+128+128+3x3+3x3+5508012173
+ $(Device/netgear_ath79_nand)
+endef
+TARGET_DEVICES += netgear_wndr4500-v3
+
define Device/zyxel_nbg6716
SOC := qca9558
DEVICE_VENDOR := ZyXEL