aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/nand.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-06-16 21:34:46 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-04 15:50:17 +0200
commit8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5 (patch)
treeb58ad085eae892fa35cb6e7a8f0b09373b5c4d3e /target/linux/ath79/image/nand.mk
parentcb689f2723b40c96426ac69f1478530ff1d48368 (diff)
downloadupstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.tar.gz
upstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.tar.bz2
upstream-8c3dbaf8b49233e275b2dce4e30dc0a2bf8c86c5.zip
ath79: split DEVICE_TITLE in multiple variables
This allows the definition of DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT. All three are merged together to look the same as the current DEVICE_TITLE. Also, if DEVICE_TITLE is set it's directly used as a *fallback* for devices which weren't upgraded yet. This is based on the work of @sudhanshu16. The motivation is to create JSON files based on provided metadata, needing clear differentiation between vendor, model and revision. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux/ath79/image/nand.mk')
-rw-r--r--target/linux/ath79/image/nand.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index eee419194b..f6eab3567f 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -1,6 +1,7 @@
define Device/glinet_gl-ar300m-nand
ATH_SOC := qca9531
- DEVICE_TITLE := GL-AR300M (NAND)
+ DEVICE_MODEL := GL-AR300M
+ DEVICE_VARIANT := NAND
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport
KERNEL_SIZE := 2048k
BLOCKSIZE := 128k