aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/nand.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 22:58:27 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-21 20:02:55 +0100
commit3f14f034fb5e191f4a537998379d8e922ec31e8a (patch)
tree2daa222bf570dcd278377f8fe4c8969a92d4ead0 /target/linux/ath79/image/nand.mk
parent1444e31a7bf54b796f8ef88e77fee255b959c6bb (diff)
downloadupstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.gz
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.bz2
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.zip
treewide: omit IMAGE_SIZE argument from check-size
Now that check-size uses IMAGE_SIZE by default, we can skip the argument from image recipes to reduce redundancy. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/nand.mk')
-rw-r--r--target/linux/ath79/image/nand.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 7d283b54c4..3ccd19914f 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -43,7 +43,7 @@ define Device/aerohive_hiveap-121
SUPPORTED_DEVICES += hiveap-121
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
TARGET_DEVICES += aerohive_hiveap-121
@@ -62,7 +62,7 @@ define Device/domywifi_dw33d
IMAGES += factory.bin
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
TARGET_DEVICES += domywifi_dw33d
@@ -145,9 +145,9 @@ define Device/netgear_ath79_nand
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
IMAGES := sysupgrade.bin factory.img
IMAGE/factory.img := append-kernel | append-ubi | netgear-dni | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
UBINIZE_OPTS := -E 5
endef