aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/nand.mk
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-05-29 03:02:59 -0500
committerJohn Crispin <john@phrozen.org>2018-06-18 20:29:38 +0200
commit0e81968ee8def1d477f12d1eeb63f485c551463e (patch)
treebe167a805c372dadce271b9352c884152e0a9cb7 /target/linux/ath79/image/nand.mk
parentfe3b62bbdc66a50c985ba3b0c9e873e5c0862ee2 (diff)
downloadupstream-0e81968ee8def1d477f12d1eeb63f485c551463e.tar.gz
upstream-0e81968ee8def1d477f12d1eeb63f485c551463e.tar.bz2
upstream-0e81968ee8def1d477f12d1eeb63f485c551463e.zip
ath79: add initial nand support for gl-ar300m
Signed-off-by: Marty E. Plummer <hanetzer@startmail.com>
Diffstat (limited to 'target/linux/ath79/image/nand.mk')
-rw-r--r--target/linux/ath79/image/nand.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
new file mode 100644
index 0000000000..979afd2b2b
--- /dev/null
+++ b/target/linux/ath79/image/nand.mk
@@ -0,0 +1,13 @@
+define Device/glinet_ar300m_nand
+ ATH_SOC := qca9533
+ DEVICE_TITLE := GL-AR300M (NAND)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport
+ KERNEL_SIZE := 2048k
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ VID_HDR_OFFSET := 512
+ IMAGES := factory.ubi sysupgrade.tar
+ IMAGE/sysupgrade.tar := sysupgrade-tar
+ IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+endef
+TARGET_DEVICES += glinet_ar300m_nand