aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/lzma-loader/Makefile
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 21:01:32 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 22:25:53 +0200
commitc57e182b560e4c93377270d470600095c2b580fe (patch)
treef8c6eb4387902378e6bad9d3dbd5abbfa1a79d27 /target/linux/ath79/image/lzma-loader/Makefile
parent108a6f6792bc50fa5b1627c207ae71ba555b55f8 (diff)
downloadupstream-c57e182b560e4c93377270d470600095c2b580fe.tar.gz
upstream-c57e182b560e4c93377270d470600095c2b580fe.tar.bz2
upstream-c57e182b560e4c93377270d470600095c2b580fe.zip
ath79: lzma-loader: sync with ar71xx target
Import all improvements made in the lzma-loader since development on the ath79 target started. This also reverts fe594bf90d09 ("ath79: fix loader-okli, lzma-loader"), as is obsoleted by 2ad60168b6af ("ar71xx: lzma-loader: move padding workaround to gzip step"). Likely, many of the changes should be ported to the ramips lzma-loader as well, but I don't have a device to test this. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux/ath79/image/lzma-loader/Makefile')
-rw-r--r--target/linux/ath79/image/lzma-loader/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ath79/image/lzma-loader/Makefile b/target/linux/ath79/image/lzma-loader/Makefile
index 9b81e87306..738093a958 100644
--- a/target/linux/ath79/image/lzma-loader/Makefile
+++ b/target/linux/ath79/image/lzma-loader/Makefile
@@ -47,7 +47,11 @@ loader-compile: $(PKG_BUILD_DIR)/.prepared
clean all
loader.gz: $(PKG_BUILD_DIR)/loader.bin
- gzip -nc9 $< > $(LOADER_GZ)
+ # Workaround for buggy bootloaders: Some devices
+ # (TP-Link TL-WR1043ND v1) don't work correctly when
+ # the uncompressed loader is too small (probably a cache
+ # invalidation issue)
+ dd if=$< bs=512K conv=sync | gzip -nc9 > $(LOADER_GZ)
loader.elf: $(PKG_BUILD_DIR)/loader.elf
$(CP) $< $(LOADER_ELF)