aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-05-19 22:49:35 +0200
committerDavid Bauer <mail@david-bauer.net>2020-05-22 21:54:30 +0200
commitebddc5f984a240980303aed68524eb615484eef8 (patch)
treef8eacc7f4ea3b557fa3163119e9c5bedcbdcf795 /target/linux/ath79/image/generic.mk
parenta9f75101508f64306710590bf45a326d4c2a1970 (diff)
downloadupstream-ebddc5f984a240980303aed68524eb615484eef8.tar.gz
upstream-ebddc5f984a240980303aed68524eb615484eef8.tar.bz2
upstream-ebddc5f984a240980303aed68524eb615484eef8.zip
ath79: add support for Enterasys WS-AP3705i
Hardware -------- SoC: Atheros AR9344 RAM: 128M DDR2 FLASH: 2x Macronix MX25L12845EM 2x 16MiB SPI-NOR WLAN2: Atheros AR9344 2x2 2T2R WLAN5: Atheros AR9580 2x2 2T2R SERIAL: Cisco-RJ45 on the back (115200 8n1) Installation ------------ The U-Boot CLI is password protected (using the same credentials as the OS). Default is admin/new2day. 1. Download the OpenWrt initramfs-image. Place it into a TFTP server root directory and rename it to 1401A8C0.img. Configure the TFTP server to listen at 192.168.1.66/24. 2. Connect the TFTP server to the access point. 3. Connect to the serial console of the access point. Attach power and interrupt the boot procedure when prompted (bootdelay is 1 second). 4. Configure the U-Boot environment for booting OpenWrt from Ram and flash: $ setenv boot_openwrt 'setenv bootargs; bootm 0xbf230000' $ setenv ramboot_openwrt 'setenv serverip 192.168.1.66; tftpboot 0x85000000; bootm' $ setenv bootcmd 'run boot_openwrt' $ saveenv 5. Load OpenWrt into memory: $ run ramboot_openwrt Wait for the image to boot. 6. Transfer the OpenWrt sysupgrade image to the device. Write the image to flash using sysupgrade: $ sysupgrade -n /path/to/openwrt-sysuograde.bin Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 8d8767ddf6..7f06740c98 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -630,6 +630,14 @@ define Device/engenius_ews511ap
endef
TARGET_DEVICES += engenius_ews511ap
+define Device/enterasys_ws-ap3705i
+ SOC := ar9344
+ DEVICE_VENDOR := Enterasys
+ DEVICE_MODEL := WS-AP3705i
+ IMAGE_SIZE := 30528k
+endef
+TARGET_DEVICES += enterasys_ws-ap3705i
+
define Device/etactica_eg200
SOC := ar9331
DEVICE_VENDOR := eTactica