aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2020-11-23 13:41:34 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-06-05 01:17:11 +0200
commiteaf2e32c12655d7fb58e158086a784393dc6f69a (patch)
tree06ae5016fcd221b8b461df3b5a85e29d457ef1a1 /target/linux/ath79/image/generic.mk
parent3394af677cadd1f9b877100312c830d87488fcfb (diff)
downloadupstream-eaf2e32c12655d7fb58e158086a784393dc6f69a.tar.gz
upstream-eaf2e32c12655d7fb58e158086a784393dc6f69a.tar.bz2
upstream-eaf2e32c12655d7fb58e158086a784393dc6f69a.zip
ath79: Add support for OpenMesh A60
Device specifications: ====================== * Qualcomm/Atheros QCA9558 ver 1 rev 0 * 720/600/240 MHz (CPU/DDR/AHB) * 128 MB of RAM * 16 MB of SPI NOR flash - 2x 7 MB available; but one of the 7 MB regions is the recovery image * 3T3R 2.4 GHz Wi-Fi (11n) * 3T3R 5 GHz Wi-Fi (11ac) * multi-color LED (controlled via red/green/blue GPIOs) * 1x GPIO-button (reset) * external h/w watchdog (enabled by default)) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 2x ethernet - eth0 + Label: Ethernet 1 + AR8035 ethernet PHY (RGMII) + 10/100/1000 Mbps Ethernet + 802.3af POE + used as WAN interface - eth1 + Label: Ethernet 2 + AR8031 ethernet PHY (SGMII) + 10/100/1000 Mbps Ethernet + used as LAN interface * 1x USB * internal antennas Flashing instructions: ====================== Various methods can be used to install the actual image on the flash. Two easy ones are: ap51-flash ---------- The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the image to the u-boot when the device boots up. initramfs from TFTP ------------------- The serial console must be used to access the u-boot shell during bootup. It can then be used to first boot up the initramfs image from a TFTP server (here with the IP 192.168.1.21): setenv serverip 192.168.1.21 setenv ipaddr 192.168.1.1 tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr The actual sysupgrade image can then be transferred (on the LAN port) to the device via scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/ On the device, the sysupgrade must then be started using sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin Signed-off-by: Sven Eckelmann <sven@narfation.org>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 2e23e4e72c..7c26f5dc1f 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1628,6 +1628,16 @@ define Device/openmesh_common_256k
openmesh-image ce_type=$$$$(OPENMESH_CE_TYPE) | append-metadata
endef
+define Device/openmesh_a60
+ $(Device/openmesh_common_64k)
+ SOC := qca9558
+ DEVICE_MODEL := A60
+ DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct kmod-usb2
+ OPENMESH_CE_TYPE := A60
+ SUPPORTED_DEVICES += a60
+endef
+TARGET_DEVICES += openmesh_a60
+
define Device/openmesh_mr600-v1
$(Device/openmesh_common_64k)
SOC := ar9344