aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2020-08-19 16:01:25 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2020-09-28 01:28:37 +0200
commite9263123f9f65814b8858efb5b79d58fe05ca732 (patch)
tree7d4cb83709b37e907240c700a520a73a7b4b27d0 /target/linux/ath79/image/generic.mk
parentb33ce8c5355eec61663ce0ac789118f82041045f (diff)
downloadupstream-e9263123f9f65814b8858efb5b79d58fe05ca732.tar.gz
upstream-e9263123f9f65814b8858efb5b79d58fe05ca732.tar.bz2
upstream-e9263123f9f65814b8858efb5b79d58fe05ca732.zip
ath79: add support for Hak5 WiFi Pineapple NANO
Hak5 WiFi Pineapple NANO is an "USB dongle" device dedicated for Wi-Fi pentesters. This device is based on Atheros AR9331 and AR9271. Support for it was first introduced in 950b278c81 (ar71xx). FCC ID: 2AB87-NANO. Specifications: - Atheros AR9331 - 400/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR1) - 16 MB of flash (SPI NOR) - 1T1R 2.4 GHz Wi-Fi (AR9331) - 1T1R 2.4 GHz Wi-Fi (AR9271L), with ext. PA and LNA (Qorvo RFFM4203) - 2x RP-SMA antenna connectors - 1x USB 2.0 to 10/100 Ethernet bridge (ASIX AX88772A) - integrated 4-port USB 2.0 HUB: Alcor Micro AU6259: - 1x USB 2.0 - 1x microSD card reader (Genesys Logic GL834L) - Atheros AR9271L - 1x LED, 1x button - UART (4-pin, 2 mm pitch) header on PCB - USB 2.0 Type-A plug for power and AX88772A Flash instruction: You can use sysupgrade image directly in vendor firmware which is based on OpenWrt/LEDE. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index a5f282be9b..c0aacd7ff9 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1045,6 +1045,19 @@ define Device/hak5_packet-squirrel
endef
TARGET_DEVICES += hak5_packet-squirrel
+define Device/hak5_wifi-pineapple-nano
+ $(Device/tplink-16mlzma)
+ SOC := ar9331
+ DEVICE_VENDOR := Hak5
+ DEVICE_MODEL := WiFi Pineapple NANO
+ TPLINK_HWID := 0x4e414e4f
+ IMAGES := sysupgrade.bin
+ DEVICE_PACKAGES := kmod-ath9k-htc kmod-usb-chipidea2 kmod-usb-storage \
+ -swconfig -uboot-envtools
+ SUPPORTED_DEVICES += wifi-pineapple-nano
+endef
+TARGET_DEVICES += hak5_wifi-pineapple-nano
+
define Device/iodata_etg3-r
SOC := ar9342
DEVICE_VENDOR := I-O DATA