aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDaniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>2018-08-31 19:28:35 -0700
committerPetr Štetiar <ynezz@true.cz>2019-07-17 22:59:29 +0200
commitbc18c2bfe7a80630eea15aa71800b0829ce32634 (patch)
tree8c0be4b88f8b3b7205e0e3bf4ee2696889f0a961 /target/linux/ath79/image/generic.mk
parenta9fa91d200d6427ca6b8e6637cb7a2e8c59d18af (diff)
downloadupstream-bc18c2bfe7a80630eea15aa71800b0829ce32634.tar.gz
upstream-bc18c2bfe7a80630eea15aa71800b0829ce32634.tar.bz2
upstream-bc18c2bfe7a80630eea15aa71800b0829ce32634.zip
ath79: add support for Bluesocket BSAP1880 board
This board was used in dual-band 802.11n enterprise access points, models BSAP-1800v2 and BSAP-1840, introduced in 2010 by Bluesocket, which was acquired by Adtran in 2011, who has now EOL'ed them. They differed only in that the BSAP-1840's antennae were detachable, while the BSAP-1800v2's were inside the case. They have an external RJ-45 console port, which works with standard Cisco 72-3383-01 console cables. Specification: - System-On-Chip: AR7161 - CPU/Speed: 600 MHz - Flash-Chip: Macronix MX25L12845E - Flash size: 16 MiB - RAM: 64 MiB - Wireless No1: Lite-On WN2601A card: AR9160/AR9103 2.4GHz 802.11bgn - Wireless No2: Lite-On WN2502A card: AR9160/AR9106 5GHz 802.11an - PHY: Vitesse VSC8601, Rev. B Installation: 1. Connect to the serial console using a terminal that supports YMODEM at 115200 bps, 8 data bits, no parity, 1 stop bit 2. Interrupt the bootloader using its password, which is: r00t 3. Issue the "fis init" command, confirming if prompted 4. Look at the length of the openwrt-ath79-generic-*-squashfs-kernel.bin file, and substitute it below, instead of where I have "LeNgTh" 5. Issue the following command, and upload this file using YMODEM protocol load -r -v -b 0x80060000 -m ymodem 6. Issue the following commands, substituting as mentioned above: fis create -b 0x80060000 -l LeNgTh vmlinux_2 load -r -v -b 0x80100000 -m ymodem 7. Using YMODEM, upload openwrt-ath79-generic-*-squashfs-rootfs.bin 8. Issue the "fis free" command, and for the first range in its response, use a hexadecimal calculator to subtract the start from the end in order to substitute it below, with the leading "0x" to specify it in hexadecimal, instead of where I have "LeNgTh" 9. Issue the following commands, substituting as mentioned above: fis create -b 0x80100000 -l LeNgTh -e 0 -r 0 rootfs reset 10.Wait for the status LED to go solid green Tested-by: Brian Gonyer <bgonyer@gmail.com> Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us> [fixed obsolete $ARGV in platform_do_upgrade] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4662383541..3c679fb480 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -85,6 +85,32 @@ define Device/8dev_carambola2
endef
TARGET_DEVICES += 8dev_carambola2
+define Device/adtran_bsap1880
+ ATH_SOC := ar7161
+ DEVICE_VENDOR := Adtran/Bluesocket
+ DEVICE_PACKAGES += -swconfig -uboot-envtools fconfig
+ KERNEL := kernel-bin | append-dtb | lzma
+ KERNEL_INITRAMFS := kernel-bin | append-dtb
+ IMAGE_SIZE := 11200k
+ IMAGES += kernel.bin rootfs.bin
+ IMAGE/kernel.bin := append-kernel | pad-to $$$$(BLOCKSIZE)
+ IMAGE/rootfs.bin := append-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+
+define Device/adtran_bsap1800-v2
+ $(Device/adtran_bsap1880)
+ DEVICE_MODEL := BSAP-1800
+ DEVICE_VARIANT := v2
+endef
+TARGET_DEVICES += adtran_bsap1800-v2
+
+define Device/adtran_bsap1840
+ $(Device/adtran_bsap1880)
+ DEVICE_MODEL := BSAP-1840
+endef
+TARGET_DEVICES += adtran_bsap1840
+
define Device/aruba_ap-105
ATH_SOC := ar7161
DEVICE_VENDOR := Aruba