aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorJeff Kletsky <git-commits@allycomm.com>2019-06-02 06:43:00 -0700
committerChuanhong Guo <gch981213@gmail.com>2019-11-14 14:38:58 +0800
commitb591cabd3989b44cfaf15248af9e55a0300a9c0a (patch)
tree6da83d8d578dc7c1a6cd152ebc7a77b759aa34b1 /target/linux/ath79/image/generic.mk
parent55e6c903ae20bd8e694f4626166766e59602f87c (diff)
downloadupstream-b591cabd3989b44cfaf15248af9e55a0300a9c0a.tar.gz
upstream-b591cabd3989b44cfaf15248af9e55a0300a9c0a.tar.bz2
upstream-b591cabd3989b44cfaf15248af9e55a0300a9c0a.zip
ath79: add GL.iNet GL-AR300M16 as NOR-only board
The GL.iNet GL-AR300M series of devices includes variants without NAND and only the 16 MB NOR flash. These include the GL-AR300M16 and the GL-AR300M-Lite (already with its own board name). This board-name addition provides disambiguation from the NAND-bearing GL-AR300M devices, both for OpenWrt code and for end users. Kernel and firmware support for NAND and UBI will add ~320 kB to the overall firmware size at this time. This NOR-only option continues to provide more compact firmware for both the GL-AR300M16 as well as those who wish to use it as an alternate or primary, NOR-resident firmware on the GL-AR300M. The ar71xx targets are unmodified. Installation ------------ Install through OEM U-Boot (HTTP-based) or `sysupgrade --force` when booted from NOR and running OEM or OpenWrt, NOR-based firmware. As one of the intentions is disambiguation from NAND-bearing units, users who have flashed this firmware onto a device with NAND would need to use U-Boot or `sysupgrade --force` to flash firmware that again supports NAND. There are no additional SUPPORTED_DEVICES as it is not possible to determine if a device does or does not have NAND based on either the OEM's or OpenWrt's board names prior to this patch. Signed-off-by: Jeff Kletsky <git-commits@allycomm.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 011bb41262..6fc51ec647 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -562,6 +562,12 @@ define Device/glinet_gl-ar300m-lite
endef
TARGET_DEVICES += glinet_gl-ar300m-lite
+define Device/glinet_gl-ar300m16
+ $(Device/glinet_gl-ar300m-common-nor)
+ DEVICE_MODEL := GL-AR300M16
+endef
+TARGET_DEVICES += glinet_gl-ar300m16
+
define Device/glinet_gl-ar750
ATH_SOC := qca9531
DEVICE_VENDOR := GL.iNet