aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorGiulio Lorenzo <salveenee@mortemale.org>2020-10-06 14:14:31 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-05-17 01:01:32 +0200
commitb108ed0ab09492d8d5a1775714da1ee34ce475ee (patch)
tree8c742e2a09dd6bf5ca8150b62134cdc0eb43f533 /target/linux/ath79/image/generic.mk
parent3dd9f82fecd3a13ff4fa9d109bbe5b137df3f787 (diff)
downloadupstream-b108ed0ab09492d8d5a1775714da1ee34ce475ee.tar.gz
upstream-b108ed0ab09492d8d5a1775714da1ee34ce475ee.tar.bz2
upstream-b108ed0ab09492d8d5a1775714da1ee34ce475ee.zip
ath79: add support for ZiKing CPE46B
ZiKing CPE46B is a POE outdoor 2.4ghz device with an integrated directional antenna. It is low cost and mostly available via Aliexpress, references can be found at: - https://forum.openwrt.org/t/anddear-ziking-cpe46b-ar9331-ap121/60383 - https://git.lsd.cat/g/openwrt-cpe46b Specifications: - Atheros AR9330 - 32MB of RAM - 8MB of flash (SPI NOR) - 1 * 2.4ghz integrated antenna - 2 * 10/100/1000 ethernet ports (1 POE) - 3 * Green LEDs controlled by the SoC - 3 * Green LEDs controlled via GPIO - 1 * Reset Button controlled via GPIO - 1 * 4 pin serial header on the PCB - Outdoor packaging Flashing instruction: You can use sysupgrade image directly in vendor firmware which is based on OpenWrt/LEDE. In case of issues with the vendor GUI, the vendor Telnet console is vulnerable to command injection and can be used to gain a shell directly on the OEM OpenWrt distribution. Signed-off-by: Giulio Lorenzo <salveenee@mortemale.org> [fix whitespaces, drop redundant uart status and serial0, drop num-chipselects, drop 0x1002 MAC address for wmac] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 8c21fdc7f0..2e23e4e72c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2232,6 +2232,15 @@ define Device/yuncore_xd4200
endef
TARGET_DEVICES += yuncore_xd4200
+define Device/ziking_cpe46b
+ SOC := ar9330
+ DEVICE_VENDOR := ZiKing
+ DEVICE_MODEL := CPE46B
+ IMAGE_SIZE := 8000k
+ DEVICE_PACKAGES := kmod-i2c-gpio
+endef
+TARGET_DEVICES += ziking_cpe46b
+
define Device/zbtlink_zbt-wd323
SOC := ar9344
DEVICE_VENDOR := ZBT