aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorJoan Moreau <jom@grosjo.net>2019-03-30 13:27:17 +0000
committerDavid Bauer <mail@david-bauer.net>2019-08-09 07:49:21 +0200
commitabbbecaa73dcb5a36932a224f74488d0c5e3b3cd (patch)
treef3771356412722d14699e00ff96969303dd9b465 /target/linux/ath79/image/generic.mk
parentccb4b96b8a4990178512c7a785f998a5e6f74cc3 (diff)
downloadupstream-abbbecaa73dcb5a36932a224f74488d0c5e3b3cd.tar.gz
upstream-abbbecaa73dcb5a36932a224f74488d0c5e3b3cd.tar.bz2
upstream-abbbecaa73dcb5a36932a224f74488d0c5e3b3cd.zip
ath79: add support for Comfast E314N-v2
Taken code from https://patchwork.ozlabs.org/patch/884850/ that was never pushed by the author, and adapted to ath79. The Comfast E314N-V2 is a 2.4 GHz 2x2 radio with a built-in directional antenna and a second Ethernet port - very similar to the Ubiquiti NanoStation M2. The Ethernet port features a pass-through PoE capability, enabled or disabled with a slide switch. Specifications : - System-On-Chip: Qualcomm/Atheros QCA9531 - CPU/Speed: 650 MHz - Flash size: 8 MiB - RAM: 64 MiB - 2 Ethernet 1Gbp - 1 reset button - 1 switch to choose PoE from LAN or Wan. 48Vdc - Wifi 2.4 Ghz (b/g/n) - UART inside the box (3.3V, pins marked on the PCB) Firmware can be flashed on these units by the following method: 1.) Apply power to the unit 2.) Immediately AFTER applying power, hold down the reset button 3.) The WAN, LAN, and wireless lights will flash - wait three seconds (three flashes) and then release the button. 4.) After a second, the lights will flutter quickly and the unit will be visible at 192.168.1.1. A web page will be available to enable quick and simple uploading and flashing of firmware. During the boot process, these units also look for a tftp server at 192.168.1.10. If one is present, the firmware can be uploaded as a file called firmware-auto.bin Signed-off-by: Joan Moreau <jom@grosjo.net> [wrapped commit message - fix commit title capitalization] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 5127cfd510..7ceb5a8867 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -256,6 +256,15 @@ define Device/comfast_cf-e120a-v3
endef
TARGET_DEVICES += comfast_cf-e120a-v3
+define Device/comfast_cf-e314n-v2
+ ATH_SOC := qca9531
+ DEVICE_VENDOR := COMFAST
+ DEVICE_MODEL := CF-E314N
+ DEVICE_VARIANT := v2
+ DEVICE_PACKAGES := rssileds
+endef
+TARGET_DEVICES += comfast_cf-e314n-v2
+
define Device/comfast_cf-e5
ATH_SOC := qca9531
DEVICE_VENDOR := COMFAST