aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorJoan Moreau <jom@grosjo.net>2019-03-31 04:26:22 +0000
committerDavid Bauer <mail@david-bauer.net>2019-08-09 17:07:07 +0200
commit9ed272fe950029c88189ba24d4b3594cd52c176c (patch)
tree67d0fdd37fa144b586ca01ae60592475b32e1d1d /target/linux/ath79/image/generic.mk
parentd8c62c40297feabb6bfd2c091588070a2e3fc11c (diff)
downloadupstream-9ed272fe950029c88189ba24d4b3594cd52c176c.tar.gz
upstream-9ed272fe950029c88189ba24d4b3594cd52c176c.tar.bz2
upstream-9ed272fe950029c88189ba24d4b3594cd52c176c.zip
ath79: add support for Comfast WR650AC v1/v2
This is a dual band 11a/11n router with 1x wan and 4x gig lan ports. There are two versions of this router which can be identified through the factory web interface, v1 has 128mb ram and a uboot size of 128k, v2 has 256mb ram and a uboot size of 256k, the remaining hardware and PCB markings are the same. Short specification: SoC: Qualcomm Atheros QCA9558 - 720 MHz Switch: Atheros AR8327 Second radio : Qualcomm Atheros QCA9880 802.11ac 4 LAN/1 WAN 1000Mps Ethernet 256 MB of RAM (DDR2) 16 MB of FLASH 3x2.4 GHz, 3x5GHz antennas Steps to install : Option A : Use vendor UI Option B (if A is not working) : (a) Download 'backup' from vendor UI and rename it backup.tar.gz (b) Open the archive, and update the root password in /etc/shadow by '$1$9wX3HGfB$X5Sb3kqzzBLdKRUR2kfFd0' (c) 'Restore' from the archive using the vendor UI. Root password is now 'aaa' (d) Scp the firwmware to the device: $ scp <openwrt-sysupgrade>.bin root@192.168.1.1:/ (d) ssh to the device and flash the firmware: $ cd / $ mtd -e firmware -r write <openwrt-sysupgrade>.bin firmware Signed-off-by: Gareth Parker <gareth41@orcon.net.nz> Signed-off-by: Ding Tengfei <dtf@comfast.cn> Signed-off-by: Joan Moreau <jom@grosjo.net> [reformatted commit message] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 7ceb5a8867..149e4ed300 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -275,6 +275,24 @@ define Device/comfast_cf-e5
endef
TARGET_DEVICES += comfast_cf-e5
+define Device/comfast_cf-wr650ac-v1
+ ATH_SOC := qca9558
+ DEVICE_VENDOR := COMFAST
+ DEVICE_MODEL := CF-WR650AC
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += comfast_cf-wr650ac-v1
+
+define Device/comfast_cf-wr650ac-v2
+ ATH_SOC := qca9558
+ DEVICE_VENDOR := COMFAST
+ DEVICE_MODEL := CF-WR650AC
+ DEVICE_VARIANT := v2
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += comfast_cf-wr650ac-v2
+
define Device/devolo_dvl1200e
ATH_SOC := qca9558
DEVICE_VENDOR := devolo