aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorLuochongjun <luochongjun@gl-inet.com>2019-08-23 17:05:57 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-08-24 08:55:33 +0800
commit921675a2d148330a7ec44f10ea4d583b8d7b5a44 (patch)
tree5b7220a2b15a6aaeb6ee1194d07b7af3e394e736 /target/linux/ath79/image/generic.mk
parentfb3574f1238cd958554d0b77f157f15508247dae (diff)
downloadupstream-921675a2d148330a7ec44f10ea4d583b8d7b5a44.tar.gz
upstream-921675a2d148330a7ec44f10ea4d583b8d7b5a44.tar.bz2
upstream-921675a2d148330a7ec44f10ea4d583b8d7b5a44.zip
ath79: add support for gl-ar750
This patch supports gl-ar750, which was previously supported by ar71xx. Specification: - SOC: QCA9531 (650MHz) - Flash: 16 MiB (W25Q128FVSG) - RAM: 128 MiB DDR2 - Ethernet: 10/100: 2xLAN + 10/100: 1xWAN - Wireless: 2.4GHz (bgn) and 5GHz (ac) - USB: 1x USB 2.0 port - Switch: 1x switch - Button: 1x reset button - LED: 3x LEDS (white) Flash instruction: Support for sysupgrade directive upgrades, as well as luci upgrades. Signed-off-by: Luochongjun <luochongjun@gl-inet.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 6f1ad5b708..eed0e2b683 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -557,6 +557,16 @@ define Device/glinet_gl-ar300m-nor
endef
TARGET_DEVICES += glinet_gl-ar300m-nor
+define Device/glinet_gl-ar750
+ ATH_SOC := qca9531
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := GL-AR750
+ DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct
+ IMAGE_SIZE := 16000k
+ SUPPORTED_DEVICES += gl-ar750
+endef
+TARGET_DEVICES += glinet_gl-ar750
+
define Device/glinet_gl-ar750s
ATH_SOC := qca9563
DEVICE_VENDOR := GL.iNet