aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-08-23 15:50:47 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-09-01 00:12:02 +0200
commit900330ff2f5cb568ff3631ebea2888956e2ed8c9 (patch)
tree26877f5dc442bdf8695601fb9fb539dce2d84c35 /target/linux/ath79/image/generic.mk
parentc1db564cbc7cad88606f3caedf81d07b0a60931f (diff)
downloadupstream-900330ff2f5cb568ff3631ebea2888956e2ed8c9.tar.gz
upstream-900330ff2f5cb568ff3631ebea2888956e2ed8c9.tar.bz2
upstream-900330ff2f5cb568ff3631ebea2888956e2ed8c9.zip
ath79: image: retire combined-image for Adtran/Bluesocket devices
During review it slipped by that these devices use combined-image which should never be used for newly added ones. Therefore switch to sysupgrade-tar generated images introduced in 8f6f260 ("ath79: routerstation: prepare to use sysupgrade-tar format image"). The sysupgrade accepts both images for now so no reression should occur. Cc: Brian Gonyer <bgonyer@gmail.com> Cc: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us> Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index eed0e2b683..fe80be980c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -108,7 +108,7 @@ define Device/adtran_bsap1880
IMAGES += kernel.bin rootfs.bin
IMAGE/kernel.bin := append-kernel | pad-to $$$$(BLOCKSIZE)
IMAGE/rootfs.bin := append-rootfs | pad-rootfs
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
endef
define Device/adtran_bsap1800-v2