aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorPramod Pancha <pancha@vill.com>2019-07-05 13:45:19 -0400
committerPetr Štetiar <ynezz@true.cz>2019-07-18 00:06:55 +0200
commit8e384ba8307742b54b2be326697a5dc2dec6880b (patch)
tree4d5d2ed684c7b97fb33144a4eef2e246fc0d13f9 /target/linux/ath79/image/generic.mk
parent6fde0b735c455f834b1ffc10d38c24f056839b29 (diff)
downloadupstream-8e384ba8307742b54b2be326697a5dc2dec6880b.tar.gz
upstream-8e384ba8307742b54b2be326697a5dc2dec6880b.tar.bz2
upstream-8e384ba8307742b54b2be326697a5dc2dec6880b.zip
ath79: add support for Trendnet TEW-823DRU
Trendnet TEW-823DRU is a dual-band AC1750 router. The router is based on Qualcomm/Atheros QCA9558 + QCA9880. Specification: 720 MHz CPU 256 MB of RAM 16 MB of FLASH 3T3R 2.4 GHz 3T3R 5 GHz 5x 10/100/1000 Mbps Ethernet Firmware can be flashed from the web interface. Tested on 3 routers with no issues. Signed-off-by: Pramod Pancha <pancha@vill.com> [whitespace fixes] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 3c679fb480..51adedd6ce 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -775,6 +775,22 @@ define Device/rosinson_wr818
endef
TARGET_DEVICES += rosinson_wr818
+define Device/trendnet_tew-823dru
+ ATH_SOC := qca9558
+ DEVICE_VENDOR := Trendnet
+ DEVICE_MODEL := TEW-823DRU
+ DEVICE_VARIANT := v1.0R
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ SUPPORTED_DEVICES += tew-823dru
+ IMAGE_SIZE := 15296k
+ IMAGES := factory.bin sysupgrade.bin
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs
+ IMAGE/factory.bin := $$(IMAGE/default) | pad-offset $$$$(IMAGE_SIZE) 26 | \
+ append-string 00AP135AR9558-RT-131129-00 | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += trendnet_tew-823dru
+
define Device/wd_mynet-n750
$(Device/seama)
ATH_SOC := ar9344