aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorVincent Wiemann <vincent.wiemann@ironai.com>2019-08-13 01:26:45 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2019-11-25 17:32:46 +0100
commit8016f648640e8f73f0dc4fc307fb6bebd12afb88 (patch)
tree15a2063822888c895972172d5d6cad767addf853 /target/linux/ath79/image/generic.mk
parentc543dfe431c6328e9ddaca3514e50aa50a2935df (diff)
downloadupstream-8016f648640e8f73f0dc4fc307fb6bebd12afb88.tar.gz
upstream-8016f648640e8f73f0dc4fc307fb6bebd12afb88.tar.bz2
upstream-8016f648640e8f73f0dc4fc307fb6bebd12afb88.zip
ath79: add support for YunCore TFTP image generation
YunCore QCA9k based devices released in 2019 require a custom TFTP image for U-Boot built-in recovery mode (triggered with reset button). Image has to be prepended with 'YUNCORE' keyword followed by U-Boot CLI commands which will be executed later. Images without the custom header will be ignored by U-Boot. To be able to support both the vendor firmware (QSDK) and OpenWrt flash layouts, used here commands change the 'bootcmd' before flashing image. This commit adds generic helper script for YunCore devices with 16 MB of flash and enables TFTP image generation for A770 model. Signed-off-by: Vincent Wiemann <vincent.wiemann@ironai.com> [pepe2k@gmail.com: commit description reworded, recipe renamed] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 2396219b00..0c674cfe9a 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1,6 +1,7 @@
include ./common-buffalo.mk
include ./common-netgear.mk
include ./common-tp-link.mk
+include ./common-yuncore.mk
DEVICE_VARS += ADDPATTERN_ID ADDPATTERN_VERSION
DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
@@ -1034,6 +1035,8 @@ define Device/yuncore_a770
DEVICE_MODEL := A770
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct
IMAGE_SIZE := 16000k
+ IMAGES += tftp.bin
+ IMAGE/tftp.bin := $$(IMAGE/sysupgrade.bin) | yuncore-tftp-header-16m
endef
TARGET_DEVICES += yuncore_a770