aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorPerry Melange <isprotejesvalkata@gmail.com>2019-08-07 19:25:13 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-07 21:17:40 +0200
commit796ad2f7ef6fefcf821a3b21cadfdb7ef3126e95 (patch)
treefe459a659f69dbd28bee860efa758ce19e875a80 /target/linux/ath79/image/generic.mk
parentd7b4b5ec24184d322ccfc204c22120d5b4f02312 (diff)
downloadupstream-796ad2f7ef6fefcf821a3b21cadfdb7ef3126e95.tar.gz
upstream-796ad2f7ef6fefcf821a3b21cadfdb7ef3126e95.tar.bz2
upstream-796ad2f7ef6fefcf821a3b21cadfdb7ef3126e95.zip
ath79: add support for D-Link DIR-842 C3
Hardware spec of DIR-842 C3: SoC: QCA9563 DRAM: 128MB DDR2 Flash: 16MB SPI-NOR Switch: QCA8337N WiFi 5.8GHz: QCA9888 WiFi 2.4Ghz: QCA9563 USB: circuit onboard, but components are not soldered Flash instructions: 1. Upgrade the factory.bin through the factory web interface or the u-boot failsafe interface. The firmware will boot up correctly for the first time. Do not power off the device after OpenWrt has booted. Otherwise the u-boot will enter failsafe mode as the checksum of the firmware has been changed. 2. Upgrade the sysupgrade.bin in OpenWrt. After upgrading completes the u-boot won't complain about the firmware checksum and it's OK to use now. 3. If you powered off the device before upgrading the sysupgrade.bin, just upgrade the factory.bin through the u-boot failsafe interface and then goto step 2. Signed-off-by: Perry Melange <isprotejesvalkata@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 8009582778..abaf1a3e07 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -399,6 +399,13 @@ define Device/dlink_dir-842-c2
endef
TARGET_DEVICES += dlink_dir-842-c2
+define Device/dlink_dir-842-c3
+ $(Device/dlink_dir-842-c)
+ DEVICE_VARIANT := C3
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+TARGET_DEVICES += dlink_dir-842-c3
+
define Device/elecom_wrc-1750ghbk2-i
ATH_SOC := qca9563
DEVICE_VENDOR := ELECOM