aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-09-05 14:51:44 +0200
committerJohn Crispin <john@phrozen.org>2018-09-26 16:39:44 +0200
commit61b5b4971e7d6aab6b0695997c3b5aaf73c53b5f (patch)
treefb05b3965b058d80e90e3a2d567da431418a401d /target/linux/ath79/image/generic.mk
parentde1c58a64bd66319e770d2587da07d8c9c90174a (diff)
downloadupstream-61b5b4971e7d6aab6b0695997c3b5aaf73c53b5f.tar.gz
upstream-61b5b4971e7d6aab6b0695997c3b5aaf73c53b5f.tar.bz2
upstream-61b5b4971e7d6aab6b0695997c3b5aaf73c53b5f.zip
mac80211: make ath10k-ct the default ath10k
We select ath10k-ct by default, but it is still possible to build the upstream version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index e968dcf92c..2727fb6ca1 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -161,7 +161,7 @@ define Device/iodata_wn-ac1167dgr
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
senao-header -r 0x30a -p 0x61 -t 2
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca988x
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
endef
TARGET_DEVICES += iodata_wn-ac1167dgr
@@ -173,14 +173,14 @@ define Device/iodata_wn-ac1600dgr2
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
senao-header -r 0x30a -p 0x60 -t 2 -v 200
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca988x
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
endef
TARGET_DEVICES += iodata_wn-ac1600dgr2
define Device/ocedo_koala
ATH_SOC := qca9558
DEVICE_TITLE := OCEDO Koala
- DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
SUPPORTED_DEVICES += koala
IMAGE_SIZE := 7424k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
@@ -198,7 +198,7 @@ TARGET_DEVICES += ocedo_raccoon
define Device/openmesh_om5p-ac-v2
ATH_SOC := qca9558
DEVICE_TITLE := OpenMesh OM5P-AC v2
- DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x om-watchdog
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct om-watchdog
IMAGE_SIZE := 7808k
SUPPORTED_DEVICES += om5p-acv2
endef
@@ -295,7 +295,7 @@ define Device/phicomm_k2t
IMAGES := sysupgrade.bin
IMAGE/default := append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
- DEVICE_PACKAGES := kmod-leds-reset kmod-ath10k ath10k-firmware-qca9888
+ DEVICE_PACKAGES := kmod-leds-reset kmod-ath10k-ct ath10k-firmware-qca9888-ct
endef
TARGET_DEVICES += phicomm_k2t