aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2019-07-04 14:08:10 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2019-07-31 08:38:01 +0200
commit334bbc51987c6694e130af25876f178babf37140 (patch)
treedfb7ba47ac3e4a296b904d895a923794b6500c26 /target/linux/ath79/image/generic.mk
parent12840674d0550e6f5aa077cd2b578988f0c07074 (diff)
downloadupstream-334bbc51987c6694e130af25876f178babf37140.tar.gz
upstream-334bbc51987c6694e130af25876f178babf37140.tar.bz2
upstream-334bbc51987c6694e130af25876f178babf37140.zip
ath79: add support for ALFA Network AP121F
This commit ports support for the ALFA Network AP121F, a pocket-size router with 1 Ethernet and 2.4 GHz WiFi based on the AR9331 SoC, to the ath79 target (it was already supported in ar71xx; see commit 0c6165d2 for more details). Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net> [pepe2k@gmail.com: fixed GPIO polarity, included USB support, changed DTS nodes order, moved WLAN LED trigger define to DTS, made U-Boot env partition writable] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index c5807f2c78..42e4271e0c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -111,6 +111,16 @@ define Device/adtran_bsap1840
endef
TARGET_DEVICES += adtran_bsap1840
+define Device/alfa-network_ap121f
+ ATH_SOC := ar9331
+ DEVICE_VENDOR := ALFA Network
+ DEVICE_MODEL := AP121F
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-chipidea2 kmod-usb-storage -swconfig
+ IMAGE_SIZE := 16064k
+ SUPPORTED_DEVICES += ap121f
+endef
+TARGET_DEVICES += alfa-network_ap121f
+
define Device/aruba_ap-105
ATH_SOC := ar7161
DEVICE_VENDOR := Aruba