aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorxixiao zheng <xixiaozheng64@gmail.com>2019-06-25 16:32:58 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-08-17 23:52:34 +0800
commit2ada2a5e5bc02a5e7b3feefbee4dec0c4c355f5b (patch)
treef93ac800e1a65aa9df885d000209dcb71578bfde /target/linux/ath79/image/generic.mk
parent2678ba909329aa8ffcf213c4b63bb1b001dd1a8c (diff)
downloadupstream-2ada2a5e5bc02a5e7b3feefbee4dec0c4c355f5b.tar.gz
upstream-2ada2a5e5bc02a5e7b3feefbee4dec0c4c355f5b.tar.bz2
upstream-2ada2a5e5bc02a5e7b3feefbee4dec0c4c355f5b.zip
ath79: add support for PISEN TS-D084
PISEN TS-D084 is an wireless router with a battery and integrated power supply based on Atheros AR9331. Specification: - 400/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 1x 10/100 Mbps Ethernet - 1T1R 2.4 GHz (AR9331) - 1x USB 2.0 Flash instruction: Upload generated factory image through web interface. Signed-off-by: xixiao zheng <xixiaozheng64@gmail.com> [wrap commit message, add flash instruction] Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 5c8826b927..6f1ad5b708 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1,5 +1,6 @@
include ./common-buffalo.mk
include ./common-netgear.mk
+include ./common-tp-link.mk
DEVICE_VARS += ADDPATTERN_ID ADDPATTERN_VERSION
DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
@@ -817,6 +818,16 @@ define Device/netgear_wndr3700v2
endef
TARGET_DEVICES += netgear_wndr3700v2
+define Device/pisen_ts-d084
+ $(Device/tplink-8mlzma)
+ ATH_SOC := ar9331
+ DEVICE_VENDOR := PISEN
+ DEVICE_MODEL := TS-D084
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-chipidea2
+ TPLINK_HWID := 0x07030101
+endef
+TARGET_DEVICES += pisen_ts-d084
+
define Device/pisen_wmb001n
ATH_SOC := ar9341
DEVICE_VENDOR := PISEN