aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-12-27 20:44:11 -0800
committerPaul Spooren <mail@aparcar.org>2023-02-04 02:35:03 +0100
commit2630e5063df0240eb0d05cd6e953b2bd412e3215 (patch)
treec420021efd2ad444bf7e4f9e83675fdd43ae483e /target/linux/ath79/image/generic.mk
parent19988b66d07f44be757c4a0e41be899dbf8c72dd (diff)
downloadupstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.gz
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.bz2
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.zip
treewide: replace wpad-basic-wolfssl default
The newly merged mbedtls backend is smaller and has fewer ABI related issues than the wolfSSL one. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 0837d37a30..d12fa7226e 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1477,7 +1477,7 @@ define Device/hak5_lan-turtle
TPLINK_HWID := 0x5348334c
IMAGES := sysupgrade.bin
DEVICE_PACKAGES := kmod-usb-chipidea2 -iwinfo -kmod-ath9k -swconfig \
- -uboot-envtools -wpad-basic-wolfssl
+ -uboot-envtools -wpad-basic-mbedtls
SUPPORTED_DEVICES += lan-turtle
endef
TARGET_DEVICES += hak5_lan-turtle
@@ -1490,7 +1490,7 @@ define Device/hak5_packet-squirrel
TPLINK_HWID := 0x5351524c
IMAGES := sysupgrade.bin
DEVICE_PACKAGES := kmod-usb-chipidea2 -iwinfo -kmod-ath9k -swconfig \
- -uboot-envtools -wpad-basic-wolfssl
+ -uboot-envtools -wpad-basic-mbedtls
SUPPORTED_DEVICES += packet-squirrel
endef
TARGET_DEVICES += hak5_packet-squirrel
@@ -1525,7 +1525,7 @@ define Device/iodata_etg3-r
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := ETG3-R
IMAGE_SIZE := 7680k
- DEVICE_PACKAGES := -iwinfo -kmod-ath9k -wpad-basic-wolfssl
+ DEVICE_PACKAGES := -iwinfo -kmod-ath9k -wpad-basic-mbedtls
endef
TARGET_DEVICES += iodata_etg3-r
@@ -1585,7 +1585,7 @@ define Device/jjplus_ja76pf2
SOC := ar7161
DEVICE_VENDOR := jjPlus
DEVICE_MODEL := JA76PF2
- DEVICE_PACKAGES += -kmod-ath9k -swconfig -wpad-basic-wolfssl -uboot-envtools fconfig kmod-hwmon-lm75
+ DEVICE_PACKAGES += -kmod-ath9k -swconfig -wpad-basic-mbedtls -uboot-envtools fconfig kmod-hwmon-lm75
LOADER_TYPE := bin
LOADER_FLASH_OFFS := 0x60000
COMPILE := loader-$(1).bin
@@ -2652,7 +2652,7 @@ define Device/teltonika_rut300
DEVICE_VENDOR := Teltonika
DEVICE_MODEL := RUT300
SUPPORTED_TELTONIKA_DEVICES := teltonika,rut30x
- DEVICE_PACKAGES := -kmod-ath9k -uboot-envtools -wpad-basic-wolfssl kmod-usb2
+ DEVICE_PACKAGES := -kmod-ath9k -uboot-envtools -wpad-basic-mbedtls kmod-usb2
IMAGE_SIZE := 15552k
IMAGES += factory.bin
IMAGE/factory.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \