aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-13 15:27:49 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-16 17:32:12 +0200
commit25f2f66eeaf720e3db154019fe0b32a146c6082f (patch)
treecce0eaace65dac9d3b2913a7ab0abb065eea434c /target/linux/ath79/image/generic.mk
parentc68105c3b4f616931444174ff6d893c8fbaf9465 (diff)
downloadupstream-25f2f66eeaf720e3db154019fe0b32a146c6082f.tar.gz
upstream-25f2f66eeaf720e3db154019fe0b32a146c6082f.tar.bz2
upstream-25f2f66eeaf720e3db154019fe0b32a146c6082f.zip
ath79: add support for Buffalo WZR-600DHP
The hardware of this device seems to be identical to WZR-HP-AG300H. It was already implemented as a clone in ar71xx. Specification: - 680 MHz CPU (Qualcomm Atheros AR7161) - 128 MiB RAM - 32 MiB Flash - WiFi 5 GHz a/n - WiFi 2.4 GHz b/g/n - 5x 1000Base-T Ethernet - 1x USB 2.0 Installation of OpenWRT from vendor firmware: - Connect to the Web-interface at http://192.168.11.1 - Go to “Administration” → “Firmware Upgrade” - Upload the OpenWrt factory image Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4b6cdaa826..7e5b09af2b 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -333,16 +333,26 @@ define Device/buffalo_bhr-4grv2
endef
TARGET_DEVICES += buffalo_bhr-4grv2
-define Device/buffalo_wzr-hp-ag300h
+define Device/buffalo_wzr_ar7161
$(Device/buffalo_common)
SOC := ar7161
- DEVICE_MODEL := WZR-HP-AG300H
BUFFALO_PRODUCT := WZR-HP-AG300H
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-leds-reset kmod-owl-loader
IMAGE_SIZE := 32320k
SUPPORTED_DEVICES += wzr-hp-ag300h
endef
+
+define Device/buffalo_wzr-600dhp
+ $(Device/buffalo_wzr_ar7161)
+ DEVICE_MODEL := WZR-600DHP
+endef
+TARGET_DEVICES += buffalo_wzr-600dhp
+
+define Device/buffalo_wzr-hp-ag300h
+ $(Device/buffalo_wzr_ar7161)
+ DEVICE_MODEL := WZR-HP-AG300H
+endef
TARGET_DEVICES += buffalo_wzr-hp-ag300h
define Device/buffalo_wzr-hp-g302h-a1a0