aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorJackson Lim <jackcolentern@gmail.com>2019-07-20 15:37:12 +0800
committerDavid Bauer <mail@david-bauer.net>2019-07-24 11:36:02 +0200
commit209b36825458a439fb9f0edd36f11e6528400f87 (patch)
tree1a473147b0cad093334294d4c160e0cfb2e8c97f /target/linux/ath79/image/generic.mk
parent1282a630272c59dfd105262772a2ca136084db03 (diff)
downloadupstream-209b36825458a439fb9f0edd36f11e6528400f87.tar.gz
upstream-209b36825458a439fb9f0edd36f11e6528400f87.tar.bz2
upstream-209b36825458a439fb9f0edd36f11e6528400f87.zip
ath79: add support for D-Link DIR-842 C2
Hardware spec of DIR-842 C2: SoC: QCA9563 DRAM: 128MB DDR2 Flash: 16MB SPI-NOR Switch: QCA8337N WiFi 5.8GHz: QCA9888 WiFi 2.4Ghz: QCA9563 USB: 2.0 Flash instructions: 1. Upgrade the factory.bin through the factory web interface or the u-boot failsafe interface. The firmware will boot up correctly for the first time. Do not power off the device after OpenWrt has booted. Otherwise the u-boot will enter failsafe mode as the checksum of the firmware has been changed. 2. Upgrade the sysupgrade.bin in OpenWrt. After upgrading completes the u-boot won't complain about the firmware checksum and it's OK to use now. 3. If you powered off the device before upgrading the sysupgrade.bin, just upgrade the factory.bin through the u-boot failsafe interface and then goto step 2. Signed-off-by: Jackson Lim <jackcolentern@gmail.com> [Reword reset-hog comment, fix formatting] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 64c92c89dc..c5807f2c78 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -355,6 +355,29 @@ define Device/dlink_dir-859-a1
endef
TARGET_DEVICES += dlink_dir-859-a1
+define Device/dlink_dir-842-c2
+ ATH_SOC := qca9563
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DIR-842
+ DEVICE_VARIANT := C2
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
+ KERNEL_INITRAMFS := $$(KERNEL) | seama
+ IMAGES += factory.bin
+ SEAMA_MTDBLOCK := 5
+ SEAMA_SIGNATURE := wrgac65_dlink.2015_dir842
+ # 64 bytes offset:
+ # - 28 bytes seama_header
+ # - 36 bytes of META data (4-bytes aligned)
+ IMAGE/default := append-kernel | uImage lzma | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
+ IMAGE/sysupgrade.bin := \
+ $$(IMAGE/default) | seama | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := \
+ $$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | check-size $$$$(IMAGE_SIZE)
+ IMAGE_SIZE := 15680k
+ DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+TARGET_DEVICES += dlink_dir-842-c2
+
define Device/elecom_wrc-1750ghbk2-i
ATH_SOC := qca9563
DEVICE_VENDOR := ELECOM