aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-10-15 14:56:12 +0200
committerJohn Crispin <john@phrozen.org>2019-10-21 13:01:10 +0200
commit1bc921f419df508c57dc07cd3e43cdf0408c17dd (patch)
tree55ec0a0615affc20dcf800cb2e2561359a9a0368 /target/linux/ath79/image/generic.mk
parentf4f483f3ff7786052b414b0cdd19cf465c3ac7f7 (diff)
downloadupstream-1bc921f419df508c57dc07cd3e43cdf0408c17dd.tar.gz
upstream-1bc921f419df508c57dc07cd3e43cdf0408c17dd.tar.bz2
upstream-1bc921f419df508c57dc07cd3e43cdf0408c17dd.zip
ath79: add support for Sitecom WLR-7100
Sitecom WLR-7100 v1 002 (marketed as X7 AC1200) is a dual band wireless router. Specification SoC: Atheros AR1022 RAM: 64 MB DDR2 Flash: 8 MB SPI NOR WIFI: 2.4 GHz 2T2R integrated 5 GHz 2T2R QCA9882 integrated (connected to PCIe lane) Ethernet: 5x 10/100/1000 Mbps QCA8337N USB: 1x 2.0 LEDS: 4x GPIO controlled, 5x switch Buttons: 2x GPIO controlled UART: row of 4 unpopulated holes near USB port, starting count from white triangle on PCB 1. VCC 3.3V, 2. GND, 3. TX, 4. RX baud: 115200, parity: none, flow control: none Installation 1. Connect to one of LAN (yellow) ethernet ports, 2. Open router configuration interface, 3. Go to Toolbox > Firmware, 4. Browse for OpenWrt factory image with dlf extension and hit Apply, 5. Wait few minutes, after the Power LED will stop blinking, the router is ready for configuration. Known issues 5GHz LED doesn't work Additional information When TX line on UART is connected, and board is switched on from power off state, the DDR memory training may fail. If connected to UART, when prompted for number on boot, one can enter number 4 to open bootloader (U-Boot) command line. OEM firmware shell password is: SitecomSenao useful for creating backup of original firmware. There is also another revision of this device (v1 001), which may or may not work with introduced images. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index acb1ab4b0b..e82e125166 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -931,6 +931,20 @@ define Device/rosinson_wr818
endef
TARGET_DEVICES += rosinson_wr818
+define Device/sitecom_wlr-7100
+ ATH_SOC := ar1022
+ DEVICE_VENDOR := Sitecom
+ DEVICE_MODEL := WLR-7100
+ DEVICE_VARIANT := v1 002
+ DEVICE_PACKAGES := ath10k-firmware-qca988x kmod-ath10k kmod-usb2
+ IMAGES += factory.dlf
+ IMAGE/factory.dlf := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+ senao-header -r 0x222 -p 0x53 -t 2
+ IMAGE_SIZE := 7488k
+endef
+TARGET_DEVICES += sitecom_wlr-7100
+
define Device/trendnet_tew-823dru
ATH_SOC := qca9558
DEVICE_VENDOR := Trendnet