aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-12-27 02:32:38 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-27 14:06:38 +0100
commit1724d4e9ed7716a5444eca42adf045c2f3afc554 (patch)
tree633979e9b4ba8d4ca6693c06ac8aae889c6d3a49 /target/linux/ath79/image/generic.mk
parent8471944325db80ca37f7c756130070d0add58ff6 (diff)
downloadupstream-1724d4e9ed7716a5444eca42adf045c2f3afc554.tar.gz
upstream-1724d4e9ed7716a5444eca42adf045c2f3afc554.tar.bz2
upstream-1724d4e9ed7716a5444eca42adf045c2f3afc554.zip
ath79: add support for devolo WiFi pro 1200e
Hardware -------- CPU: Qualcomm Atheros QCA9558 RAM: 128M DDR2 FLASH: 16MiB ETH: 1x Atheros AR8035 (PoE in) 1x Atheros AR8033 WiFi2: QCA9558 2T2R WiFi5: QCA9880 2T2R BTN: 1x Reset LED: 1x LED blue 1x LED red BEEP: 1x GPIO attached piezo beeper UART: 3.3V GND TX RX (115200-N-8) (3.3V is square pad) Header is located next to reset-button Installation ------------ Make sure you set a password for the root user as prompted on first setup! 1. Upload OpenWRT sysupgrade image via SSH to the device. Use /tmp as the destination folder on the device. User is root, password the one set in the web interface. 2. Install OpenWRT with > sysupgrade -n -F /tmp/<openwrt-image-name> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index badfa7cbab..ef8cf170de 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -138,6 +138,14 @@ define Device/buffalo_wzr-hp-g450h
endef
TARGET_DEVICES += buffalo_wzr-hp-g450h
+define Device/devolo_dvl1200e
+ ATH_SOC := qca9558
+ DEVICE_TITLE := devolo WiFi pro 1200e
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1200e
+
define Device/dlink_dir-825-b1
ATH_SOC := ar7161
DEVICE_TITLE := D-LINK DIR-825 B1