aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-08-23 15:50:49 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-09-01 00:12:02 +0200
commit077d06a1a5a23caae4d0c53afb60913955d2a3ea (patch)
tree1b0e1832b347db99a077414e27ab0f213b4f093d /target/linux/ath79/image/generic.mk
parent8b4109c2b4d60495d046157d1baca9b1cdbf8dc8 (diff)
downloadupstream-077d06a1a5a23caae4d0c53afb60913955d2a3ea.tar.gz
upstream-077d06a1a5a23caae4d0c53afb60913955d2a3ea.tar.bz2
upstream-077d06a1a5a23caae4d0c53afb60913955d2a3ea.zip
ath79: image: append metadata to routerstations and ja76pf2 images
This target enforces metadata check so add the necessary information. It was previously removed because md5 sum check. When using these sysupgrade images on ar71xx target the check would complain about them not matching. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index fe80be980c..941e007a47 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -653,7 +653,7 @@ define Device/jjplus_ja76pf2
DEVICE_VENDOR := jjPlus
DEVICE_MODEL := JA76PF2
DEVICE_PACKAGES += -kmod-ath9k -swconfig -wpad-mini -uboot-envtools fconfig
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | append-metadata | check-size $$$$(IMAGE_SIZE)
# IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
KERNEL_INITRAMFS := kernel-bin | append-dtb