aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorJackson Lim <jackcolentern@gmail.com>2019-07-25 22:44:11 +0800
committerDavid Bauer <mail@david-bauer.net>2019-08-05 10:54:11 +0200
commit030fc6ab6cc1f4982809b65edf9c874d9117cd1f (patch)
tree39b9328ba8fb55b1ee30c3dc648124cfc8456883 /target/linux/ath79/image/generic.mk
parent7ed643d2052381bdd0e9680ca964eb87700cbc5e (diff)
downloadupstream-030fc6ab6cc1f4982809b65edf9c874d9117cd1f.tar.gz
upstream-030fc6ab6cc1f4982809b65edf9c874d9117cd1f.tar.bz2
upstream-030fc6ab6cc1f4982809b65edf9c874d9117cd1f.zip
ath79: add support for D-Link DIR-842 C1
Hardware spec of DIR-842 C1: SoC: QCA9563 DRAM: 128MB DDR2 Flash: 16MB SPI-NOR Switch: QCA8337N WiFi 5.8GHz: QCA9888 WiFi 2.4Ghz: QCA9563 USB: circuit onboard, but components are not soldered Flash instructions: 1. Upgrade the factory.bin through the factory web interface or the u-boot failsafe interface. The firmware will boot up correctly for the first time. Do not power off the device after OpenWrt has booted. Otherwise the u-boot will enter failsafe mode as the checksum of the firmware has been changed. 2. Upgrade the sysupgrade.bin in OpenWrt. After upgrading completes the u-boot won't complain about the firmware checksum and it's OK to use now. 3. If you powered off the device before upgrading the sysupgrade.bin, just upgrade the factory.bin through the u-boot failsafe interface and then goto step 2. Signed-off-by: Jackson Lim <jackcolentern@gmail.com> [fix whitespace issues] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk17
1 files changed, 14 insertions, 3 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 42e4271e0c..8009582778 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -365,11 +365,10 @@ define Device/dlink_dir-859-a1
endef
TARGET_DEVICES += dlink_dir-859-a1
-define Device/dlink_dir-842-c2
+define Device/dlink_dir-842-c
ATH_SOC := qca9563
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-842
- DEVICE_VARIANT := C2
KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
KERNEL_INITRAMFS := $$(KERNEL) | seama
IMAGES += factory.bin
@@ -384,7 +383,19 @@ define Device/dlink_dir-842-c2
IMAGE/factory.bin := \
$$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | check-size $$$$(IMAGE_SIZE)
IMAGE_SIZE := 15680k
- DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+
+define Device/dlink_dir-842-c1
+ $(Device/dlink_dir-842-c)
+ DEVICE_VARIANT := C1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+TARGET_DEVICES += dlink_dir-842-c1
+
+define Device/dlink_dir-842-c2
+ $(Device/dlink_dir-842-c)
+ DEVICE_VARIANT := C2
+ DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9888-ct
endef
TARGET_DEVICES += dlink_dir-842-c2