aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDmitry Tunin <hanipouspilot@gmail.com>2019-08-07 23:07:33 +0300
committerChristian Lamparter <chunkeey@gmail.com>2019-09-21 23:41:31 +0200
commit00ed75f47f4726dff17c6d63d6847bc4f7a74970 (patch)
treec5891debdaec27267e34e5c3b84f3b3d37774f17 /target/linux/ath79/image/generic.mk
parentedf1c6c67abb1201b3deb8482474239e40d3d7f5 (diff)
downloadupstream-00ed75f47f4726dff17c6d63d6847bc4f7a74970.tar.gz
upstream-00ed75f47f4726dff17c6d63d6847bc4f7a74970.tar.bz2
upstream-00ed75f47f4726dff17c6d63d6847bc4f7a74970.zip
ath79: add support of Netgear WNDR3800CH
Add support for the ar71xx supported Netgear WNDR3800CH to ath79. The device is identical to WNDR3800 except NETGEAR_BOARD_ID. Signed-off-by: Dmitry Tunin <hanipouspilot@gmail.com> Reviewed-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 9ffb724c5f..3ae771b665 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -773,6 +773,17 @@ define Device/netgear_wndr3800
endef
TARGET_DEVICES += netgear_wndr3800
+define Device/netgear_wndr3800ch
+ $(Device/netgear_wndr3x00)
+ DEVICE_MODEL := WNDR3800CH
+ NETGEAR_KERNEL_MAGIC := 0x33373031
+ NETGEAR_BOARD_ID := WNDR3800CH
+ NETGEAR_HW_ID := 29763654+16+128
+ IMAGE_SIZE := 15872k
+ SUPPORTED_DEVICES += wndr3800ch
+endef
+TARGET_DEVICES += netgear_wndr3800ch
+
define Device/ocedo_koala
ATH_SOC := qca9558
DEVICE_VENDOR := Ocedo