aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2022-04-14 12:39:05 +0200
committerPetr Štetiar <ynezz@true.cz>2022-04-15 08:14:50 +0200
commit321ec22f5246aeb20f57e88ecc149a272f469bd3 (patch)
tree7e45d6966331170a3bfcc852612bf9d38cbdc4e5 /target/linux/ath79/image/generic.mk
parent708b883168e624ede9f5897a55e5e722c6881d76 (diff)
downloadupstream-321ec22f5246aeb20f57e88ecc149a272f469bd3.tar.gz
upstream-321ec22f5246aeb20f57e88ecc149a272f469bd3.tar.bz2
upstream-321ec22f5246aeb20f57e88ecc149a272f469bd3.zip
ath79: add support for Yuncore A930
Specification: - QCA9533 (650 MHz), 64 or 128MB RAM, 16MB SPI NOR - 2x 10/100 Mbps Ethernet, with 802.3at PoE support (WAN) - 2T2R 802.11b/g/n 2.4GHz Flash instructions: If your device comes with generic QSDK based firmware, you can login over telnet (login: root, empty password, default IP: 192.168.188.253), issue first (important!) 'fw_setenv' command and then perform regular upgrade, using 'sysupgrade -n -F ...' (you can use 'wget' to download image to the device, SSH server is not available): fw_setenv bootcmd "bootm 0x9f050000 || bootm 0x9fe80000" sysupgrade -n -F openwrt-...-yuncore_...-squashfs-sysupgrade.bin In case your device runs firmware with YunCore custom GUI, you can use U-Boot recovery mode: 1. Set a static IP 192.168.0.141/24 on PC and start TFTP server with 'tftp' image renamed to 'upgrade.bin' 2. Power the device with reset button pressed and release it after 5-7 seconds, recovery mode should start downloading image from server (unfortunately, there is no visible indication that recovery got enabled - in case of problems check TFTP server logs) Signed-off-by: Clemens Hopfer <openwrt@wireloss.net> Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org> (cherry picked from commit a05dcb07241aa83a4416b56201e31b4af8518981)
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 33a72358b3..dc85fb60bf 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2528,6 +2528,16 @@ define Device/yuncore_a782
endef
TARGET_DEVICES += yuncore_a782
+define Device/yuncore_a930
+ SOC := qca9533
+ DEVICE_VENDOR := YunCore
+ DEVICE_MODEL := A930
+ IMAGE_SIZE := 16000k
+ IMAGES += tftp.bin
+ IMAGE/tftp.bin := $$(IMAGE/sysupgrade.bin) | yuncore-tftp-header-16m
+endef
+TARGET_DEVICES += yuncore_a930
+
define Device/yuncore_xd3200
SOC := qca9563
DEVICE_VENDOR := YunCore